aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-10-06 01:42:06 +0800
committerdinoex <dinoex@FreeBSD.org>2011-10-06 01:42:06 +0800
commitdbb067405c153bbc73a89ecdd667f9736a2f18aa (patch)
tree4a7a61709fb67439ae5a5fafa90625bdcdda48bf /print
parent9dee1862b97871e540a7af509b4dee0858d85961 (diff)
downloadfreebsd-ports-gnome-dbb067405c153bbc73a89ecdd667f9736a2f18aa.tar.gz
freebsd-ports-gnome-dbb067405c153bbc73a89ecdd667f9736a2f18aa.tar.zst
freebsd-ports-gnome-dbb067405c153bbc73a89ecdd667f9736a2f18aa.zip
- force build with same cups client installed
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 04f6b7ae1a15..14ddbf3ae77c 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -95,6 +95,8 @@ LIB_DEPENDS+= cups.2:${PORTSDIR}/${PKGCATEGORY}/cups-client \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
+# force build if old cups is installed.
+BUILD_DEPENDS+= cups-client>=${PORTVERSION}:${PORTSDIR}/${PKGCATEGORY}/cups-client
COMMENT2= Library cupsimage
CONFIGURE_ARGS+= --disable-pdftops
INSTALL_WRKSRC= ${WRKSRC}/filter
@@ -103,10 +105,11 @@ USE_LDCONFIG= yes
PKGMESSAGE= ${NONEXISTENT}
DESCR= ${MASTERDIR}/pkg-descr.image
.else
-LIB_DEPENDS+= cups.2:${PORTSDIR}/${PKGCATEGORY}/cups-client \
- cupsimage.2:${PORTSDIR}/${PKGCATEGORY}/cups-image
+LIB_DEPENDS+= cups.2:${PORTSDIR}/${PKGCATEGORY}/cups-client
+LIB_DEPENDS+= cupsimage.2:${PORTSDIR}/${PKGCATEGORY}/cups-image
# force build if old cups is installed.
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libcups.a:${PORTSDIR}/${PKGCATEGORY}/cups-client
+BUILD_DEPENDS+= cups-client>=${PORTVERSION}:${PORTSDIR}/${PKGCATEGORY}/cups-client
+BUILD_DEPENDS+= cups-image>=${PORTVERSION}:${PORTSDIR}/${PKGCATEGORY}/cups-image
COMMENT2= Server
USE_RC_SUBR= cupsd
PLIST_SUB+= CACHEDIR="${CUPS_CACHEDIR}"