aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-03-14 05:16:26 +0800
committertijl <tijl@FreeBSD.org>2016-03-14 05:16:26 +0800
commitf796f965de09f2f0b3a7850013c300e4c4548a82 (patch)
tree18238935b06bb12336837fb81531438dd6937ffd /print
parent6632358c90aa7019d1a07fe41b65924abb9054d4 (diff)
downloadfreebsd-ports-gnome-f796f965de09f2f0b3a7850013c300e4c4548a82.tar.gz
freebsd-ports-gnome-f796f965de09f2f0b3a7850013c300e4c4548a82.tar.zst
freebsd-ports-gnome-f796f965de09f2f0b3a7850013c300e4c4548a82.zip
- Let foomatic-rip use /bin/sh instead of /bin/bash.
- Patch foomatic-rip to reset stdin after replacing the underlying file descriptor. - Remove a patch for the pdftops filter that is no longer needed. Submitted by: Alexander Zagrebin <alex@zagrebin.ru>
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile6
-rw-r--r--print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c10
-rw-r--r--print/cups-filters/files/patch-filter_pdftops.c33
3 files changed, 12 insertions, 37 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index e1fe52b88de0..0b8171d49667 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cups-filters
PORTVERSION= 1.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/cups-filters/
@@ -36,7 +36,7 @@ SHEBANG_FILES= filter/braille/drivers/generic/brftoembosser.in \
USE_GNOME= glib20
USE_RC_SUBR= cups_browsed
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
+CONFIGURE_ARGS= --with-shell=/bin/sh ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
@@ -55,8 +55,6 @@ post-patch:
@${REINPLACE_CMD} 's:-std=c++0x:-std=c++11:' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} 's|/usr/share/liblouis|${LOCALBASE}/share/liblouis|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${WRKSRC}/filter/pdftops.c
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
-e 's|README.gz|README|' \
${WRKSRC}/utils/cups-browsed.8 \
diff --git a/print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c b/print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c
new file mode 100644
index 000000000000..6d852b0802f0
--- /dev/null
+++ b/print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c
@@ -0,0 +1,10 @@
+--- filter/foomatic-rip/foomaticrip.c.orig 2015-10-20 14:59:20 UTC
++++ filter/foomatic-rip/foomaticrip.c
+@@ -656,6 +656,7 @@ int print_file(const char *filename, int
+ rip_die(EXIT_PRNERR_NORETRY_BAD_SETTINGS,
+ "Couldn't dup stdout of pdf-to-ps\n");
+
++ clearerr(stdin);
+ ret = print_file("<STDIN>", 0);
+
+ wait_for_process(renderer_pid);
diff --git a/print/cups-filters/files/patch-filter_pdftops.c b/print/cups-filters/files/patch-filter_pdftops.c
deleted file mode 100644
index a3928ea97c08..000000000000
--- a/print/cups-filters/files/patch-filter_pdftops.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- filter/pdftops.c.orig 2016-01-19 22:12:43 UTC
-+++ filter/pdftops.c
-@@ -532,12 +532,12 @@ main(int argc, /* I - Number of comm
-
- if (renderer == PDFTOPS)
- {
-- pdf_argv[0] = (char *)"pdftops";
-+ pdf_argv[0] = (char *)"%%LOCALBASE%%/bin/pdftops";
- pdf_argc = 1;
- }
- else if (renderer == GS)
- {
-- pdf_argv[0] = (char *)"gs";
-+ pdf_argv[0] = (char *)"%%LOCALBASE%%/bin/gs";
- pdf_argv[1] = (char *)"-q";
- pdf_argv[2] = (char *)"-dNOPAUSE";
- pdf_argv[3] = (char *)"-dBATCH";
-@@ -552,13 +552,13 @@ main(int argc, /* I - Number of comm
- }
- else if (renderer == PDFTOCAIRO)
- {
-- pdf_argv[0] = (char *)"pdftocairo";
-+ pdf_argv[0] = (char *)"%%LOCALBASE%%/bin/pdftocairo";
- pdf_argv[1] = (char *)"-ps";
- pdf_argc = 2;
- }
- else
- {
-- pdf_argv[0] = (char *)"acroread";
-+ pdf_argv[0] = (char *)"%%LOCALBASE%%/bin/acroread";
- pdf_argv[1] = (char *)"-toPostScript";
- pdf_argc = 2;
- }