aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-19 07:27:33 +0800
committermiwi <miwi@FreeBSD.org>2008-06-19 07:27:33 +0800
commit0ad87e911f85e17b1af9509674685de7e77888db (patch)
tree6e678d163f0b38c48e6f3c8e20d1ddb5548427ac /print
parent5b6a842a355040ae6d1abb3832e5bf47d7fa1853 (diff)
downloadfreebsd-ports-gnome-0ad87e911f85e17b1af9509674685de7e77888db.tar.gz
freebsd-ports-gnome-0ad87e911f85e17b1af9509674685de7e77888db.tar.zst
freebsd-ports-gnome-0ad87e911f85e17b1af9509674685de7e77888db.zip
texvc takes LaTeX-compatible equations and produces formatted output in
HTML, MathML, and (via LaTeX/dvips/ImageMagick) rasterized PNG images. Input data is parsed and scrutinized for safety, and the output includes an estimate of whether the code is simple enough that HTML rendering will look acceptable. WWW: http://www.mediawiki.org/wiki/Texvc PR: ports/124607 Submitted by: Max Brazhnikov <makc at issp.ac.ru>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/texvc/Makefile39
-rw-r--r--print/texvc/distinfo3
-rw-r--r--print/texvc/pkg-descr7
4 files changed, 50 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index d8c6227b34fa..21d314fc8a02 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -312,6 +312,7 @@
SUBDIR += tex-texmflocal
SUBDIR += texinfo
SUBDIR += texpower
+ SUBDIR += texvc
SUBDIR += tgif2tex
SUBDIR += tipograf
SUBDIR += tr2latex
diff --git a/print/texvc/Makefile b/print/texvc/Makefile
new file mode 100644
index 000000000000..a0630f3e5482
--- /dev/null
+++ b/print/texvc/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: texvc
+# Date created: 2008-06-14
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= texvc
+PORTVERSION= 20050202
+CATEGORIES= print
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=wikipedia
+DISTNAME= ${PORTNAME}-linux-x86-${PORTVERSION}
+
+MAINTAINER= makc@issp.ac.ru
+COMMENT= Convert latex equations to HTML, MathML, PNG
+
+USE_OCAML= yes
+NO_OCAML_RUNDEPENDS= yes
+USE_GMAKE= yes
+BUILD_WRKSRC= ${WRKSRC}/src
+
+PLIST_FILES= bin/texvc
+
+OPTIONS= RASTER "rasterization support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_RASTER)
+USE_GHOSTSCRIPT_RUN= yes
+RUN_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
+ dvips:${PORTSDIR}/print/dvipsk-tetex \
+ convert:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/texvc ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/print/texvc/distinfo b/print/texvc/distinfo
new file mode 100644
index 000000000000..6c25b5e4032b
--- /dev/null
+++ b/print/texvc/distinfo
@@ -0,0 +1,3 @@
+MD5 (texvc-linux-x86-20050202.tar.gz) = 9f57d535f6c66b3a84f743e696f7eaf3
+SHA256 (texvc-linux-x86-20050202.tar.gz) = 0ab27b1f04ba7b120042734959cc2afcde4becb61a1167e371c94948cadf24c7
+SIZE (texvc-linux-x86-20050202.tar.gz) = 159378
diff --git a/print/texvc/pkg-descr b/print/texvc/pkg-descr
new file mode 100644
index 000000000000..a80bd435adcd
--- /dev/null
+++ b/print/texvc/pkg-descr
@@ -0,0 +1,7 @@
+texvc takes LaTeX-compatible equations and produces formatted output in
+HTML, MathML, and (via LaTeX/dvips/ImageMagick) rasterized PNG images.
+Input data is parsed and scrutinized for safety, and the output includes
+an estimate of whether the code is simple enough that HTML rendering will
+look acceptable.
+
+WWW: http://www.mediawiki.org/wiki/Texvc