aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-27 03:17:09 +0800
committerbsam <bsam@FreeBSD.org>2013-09-27 03:17:09 +0800
commitb835e8e9720877ccc54a1b891d55f2c4ee5c65ab (patch)
treee2c692ccf163aefe083ed4118fbba0b387d497d3 /print
parent0a029ed56649879c8b9703946fc6c7525d8576d2 (diff)
downloadfreebsd-ports-gnome-b835e8e9720877ccc54a1b891d55f2c4ee5c65ab.tar.gz
freebsd-ports-gnome-b835e8e9720877ccc54a1b891d55f2c4ee5c65ab.tar.zst
freebsd-ports-gnome-b835e8e9720877ccc54a1b891d55f2c4ee5c65ab.zip
. support stage;
. use new LIB_DEPENDS syntax.
Diffstat (limited to 'print')
-rw-r--r--print/photoprint/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
index 6dec9e1a9bee..fe9fed7203ff 100644
--- a/print/photoprint/Makefile
+++ b/print/photoprint/Makefile
@@ -10,17 +10,17 @@ COMMENT= Utility to print multiple images per sheet
LICENSE= GPLv2
-LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client \
- expat:${PORTSDIR}/textproc/expat2 \
- gdk_pixbuf-2.0:${PORTSDIR}/graphics/gdk-pixbuf2 \
- gutenprint:${PORTSDIR}/print/gutenprint \
- lcms:${PORTSDIR}/graphics/lcms \
- netpbm:${PORTSDIR}/graphics/netpbm \
- pcre:${PORTSDIR}/devel/pcre \
- pixman:${PORTSDIR}/x11/pixman \
- png15:${PORTSDIR}/graphics/png \
- pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libgdk_pixbuf-2.0.so:${PORTSDIR}/graphics/gdk-pixbuf2 \
+ libgutenprint.so:${PORTSDIR}/print/gutenprint \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libnetpbm.so:${PORTSDIR}/graphics/netpbm \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libpixman-1.so:${PORTSDIR}/x11/pixman \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libtiff.so:${PORTSDIR}/graphics/tiff
GNU_CONFIGURE= yes
USES= desktop-file-utils gettext pkgconfig
@@ -31,7 +31,6 @@ INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|glib/gstrfuncs.h|glib.h|g' \
${WRKSRC}/gp_cppsupport/gprinter.cpp