aboutsummaryrefslogtreecommitdiffstats
path: root/russian/cyrproxy/Makefile
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1997-06-19 14:45:22 +0800
committerache <ache@FreeBSD.org>1997-06-19 14:45:22 +0800
commit1e601e40654e4c039e37a4272c846ba2209c8711 (patch)
treead9bae93a7f8a415a3004268b741e30783ff04e4 /russian/cyrproxy/Makefile
parent563c95e4b036fc108b51c45ff266bde15e6b9621 (diff)
downloadfreebsd-ports-gnome-1e601e40654e4c039e37a4272c846ba2209c8711.tar.gz
freebsd-ports-gnome-1e601e40654e4c039e37a4272c846ba2209c8711.tar.zst
freebsd-ports-gnome-1e601e40654e4c039e37a4272c846ba2209c8711.zip
Proxy to decode between common cyrillic code tables
Diffstat (limited to 'russian/cyrproxy/Makefile')
-rw-r--r--russian/cyrproxy/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/russian/cyrproxy/Makefile b/russian/cyrproxy/Makefile
new file mode 100644
index 000000000000..5c3747e3030e
--- /dev/null
+++ b/russian/cyrproxy/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: cyrproxy
+# Version required: 1.4.1
+# Date created: 20 May 1997
+# Whom: Andrey Zakhvatov
+#
+
+DISTNAME= cyrproxy-1.4.1
+CATEGORIES= russian net www
+MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/lexa/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/etc/cyrproxy
+ @ ${MKDIR} ${PREFIX}/share/cyrproxy
+ @ ${MKDIR} ${PREFIX}/share/doc/cyrproxy
+ @ ${MKDIR} ${PREFIX}/www/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/cyrproxy ${PREFIX}/libexec/cyrproxy
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpspy ${PREFIX}/libexec/tcpspy
+ ${INSTALL_PROGRAM} ${WRKSRC}/cyrcoder/cyrtrans ${PREFIX}/bin/cyrtrans
+# ${INSTALL_PROGRAM} ${WRKSRC}/cyrcoder/transfiles ${PREFIX}/bin/transfiles
+# ${INSTALL_PROGRAM} ${WRKSRC}/cyrcoder/transtree ${PREFIX}/bin/transtree
+ ${INSTALL_PROGRAM} ${WRKSRC}/discover/discover ${PREFIX}/bin/discover
+ ${INSTALL_PROGRAM} ${WRKSRC}/cyrcoder/cyrwww ${PREFIX}/www/cgi-bin/cyrwww
+ ${INSTALL_DATA} ${WRKSRC}/config.gen ${PREFIX}/etc/cyrproxy/cyrproxy.conf.sample
+.for file in alt-iso alt-koi8 alt-win iso-alt iso-koi8 iso-win koi8-alt koi8-iso koi8-mac koi8-win mac-koi8 win-alt win-iso win-koi8
+ ${INSTALL_DATA} ${WRKSRC}/tables/${file} ${PREFIX}/share/cyrproxy/${file}
+.endfor
+.for file in History README README.http
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/cyrproxy/${file}
+.endfor
+
+.include <bsd.port.mk>