aboutsummaryrefslogtreecommitdiffstats
path: root/russian/libcyrillic/files
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2004-01-07 22:59:42 +0800
committerdemon <demon@FreeBSD.org>2004-01-07 22:59:42 +0800
commit9aad7a1584c45c8d4f2c2c6b6efc7892ab703ae2 (patch)
treed5bc168cae033af37e06c077ea5ec41c3a3b7ef7 /russian/libcyrillic/files
parent18342ae89abef50ee1a229da0799ee78e52445a1 (diff)
downloadfreebsd-ports-gnome-9aad7a1584c45c8d4f2c2c6b6efc7892ab703ae2.tar.gz
freebsd-ports-gnome-9aad7a1584c45c8d4f2c2c6b6efc7892ab703ae2.tar.zst
freebsd-ports-gnome-9aad7a1584c45c8d4f2c2c6b6efc7892ab703ae2.zip
New port: libcyrillic.
This C library allows to convert cyrillic text from any to any of the following cyrillic charsets: windows-1251, koi8-r, koi8-u, iso-8859-5, x-mac-cyrillic and ibm866. Automatic detection of charset is possible for any of those. The library also contains a number of automation features and useful service wrappers that are ready to be easily plugged into any application whenever one needs more wise features instead of just dumb converting. PR: 60042 Submitted by: Pavel Novikov <pavel@ext.by>
Diffstat (limited to 'russian/libcyrillic/files')
-rw-r--r--russian/libcyrillic/files/Makefile.bsd36
1 files changed, 36 insertions, 0 deletions
diff --git a/russian/libcyrillic/files/Makefile.bsd b/russian/libcyrillic/files/Makefile.bsd
new file mode 100644
index 000000000000..907b7555f19c
--- /dev/null
+++ b/russian/libcyrillic/files/Makefile.bsd
@@ -0,0 +1,36 @@
+SRCS= cyrillic.c cyrillic.h cyrillic_export.c cyrillic_export.h
+INCS= cyrillic.h cyrillic_export.h
+LIB= cyrillic
+
+MAKEDIR= /usr/share/mk
+
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 9
+
+SHLIB_NAME!= ${MAKE} -V SHLIB_NAME LIB=${LIB} \
+ SHLIB_MAJOR=${SHLIB_MAJOR} \
+ SHLIB_MINOR=${SHLIB_MINOR} \
+ -f ${MAKEDIR}/bsd.lib.mk
+
+all: lib${LIB}.a ${SHLIB_NAME}
+
+lib${LIB}.a ${SHLIB_NAME}: ${SRCS}
+ ${MAKE} LIB=${LIB} \
+ SRCS="${SRCS}" \
+ CFLAGS="${CFLAGS}" \
+ NOPROFILE=true \
+ NOOBJ=true \
+ SHLIB_MAJOR=${SHLIB_MAJOR} \
+ SHLIB_MINOR=${SHLIB_MINOR} \
+ -f ${MAKEDIR}/bsd.lib.mk
+
+install:
+ mkdir -p ${PREFIX}/include
+ ${MAKE} LIB=${LIB} \
+ LIBDIR=${PREFIX}/lib \
+ NOPROFILE=true \
+ NOOBJ=true \
+ SHLIB_MAJOR=${SHLIB_MAJOR} \
+ SHLIB_MINOR=${SHLIB_MINOR} \
+ -f ${MAKEDIR}/bsd.lib.mk install
+ cd ${.CURDIR} && ${BSD_INSTALL_DATA} ${INCS} ${PREFIX}/include