aboutsummaryrefslogtreecommitdiffstats
path: root/russian/netscape4.language/Makefile
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1996-04-08 09:09:43 +0800
committerache <ache@FreeBSD.org>1996-04-08 09:09:43 +0800
commit300ec83498deaf29f9b0dc7acf2a09e551d0da3c (patch)
treecb8bdee267352eebb3da8b3a87eb63dcec3bc6bb /russian/netscape4.language/Makefile
parent3faf79c24714331fd02887f218c3175399df1ef2 (diff)
downloadfreebsd-ports-gnome-300ec83498deaf29f9b0dc7acf2a09e551d0da3c.tar.gz
freebsd-ports-gnome-300ec83498deaf29f9b0dc7acf2a09e551d0da3c.tar.zst
freebsd-ports-gnome-300ec83498deaf29f9b0dc7acf2a09e551d0da3c.zip
Netscape 3 russification
Diffstat (limited to 'russian/netscape4.language/Makefile')
-rw-r--r--russian/netscape4.language/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/russian/netscape4.language/Makefile b/russian/netscape4.language/Makefile
new file mode 100644
index 000000000000..148571c119e1
--- /dev/null
+++ b/russian/netscape4.language/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: netscape.language
+# Version required: 3.0b2
+# Date created: 8 Apr 1996
+# Whom: ache
+#
+# $Id: Makefile,v 1.11 1996/03/22 01:09:46 ache Exp $
+#
+
+PKGNAME= ru-netscape-3.0b2
+CATEGORIES+= russian www x11
+
+MAINTAINER= ache@FreeBSD.ORG
+
+RUN_DEPENDS += ${X11BASE}/lib/X11/nls/ru_SU.KOI8-R:${PORTSDIR}/russian/X.language
+RUN_DEPENDS += netscape:${PORTSDIR}/www/netscape3
+
+NO_PATCH= YES
+NO_EXTRACT= YES
+NO_CONFIGURE= YES
+NO_BUILD= YES
+NO_WRKDIR= YES
+NO_PACKAGE= YES
+USE_X11= YES
+
+APPDEF = ${X11BASE}/lib/X11/app-defaults
+
+# no distfile to fetch
+do-fetch:
+
+do-install:
+ if [ -f ${APPDEF}/Netscape ] ; then \
+ grep -q '\.version:.*3\.0b2$$' ${APPDEF}/Netscape || \
+ rm ${APPDEF}/Netscape; \
+ fi
+ if [ ! -f ${APPDEF}/Netscape ] ; then \
+ cp /usr/local/lib/netscape/Netscape.ad ${APPDEF}/Netscape; \
+ fi
+ cd ${APPDEF}; grep -q koi8 Netscape || \
+ patch < ${FILESDIR}/koi8-r_patch;
+
+.include <bsd.port.mk>