aboutsummaryrefslogtreecommitdiffstats
path: root/russian/xruskb/Makefile
diff options
context:
space:
mode:
authorflathill <flathill@FreeBSD.org>1998-12-06 20:19:18 +0800
committerflathill <flathill@FreeBSD.org>1998-12-06 20:19:18 +0800
commit7a7c4f38ca77b090a62972c8b1e69da6da31374d (patch)
treef7433552840c355b2af14c28d402714a6e8a24d1 /russian/xruskb/Makefile
parent4b7956397d24ea50428f108644d6924dc77def36 (diff)
downloadfreebsd-ports-gnome-7a7c4f38ca77b090a62972c8b1e69da6da31374d.tar.gz
freebsd-ports-gnome-7a7c4f38ca77b090a62972c8b1e69da6da31374d.tar.zst
freebsd-ports-gnome-7a7c4f38ca77b090a62972c8b1e69da6da31374d.zip
PR: ports/5509
Submitted by: igor@zynaps.ru A keyboard layout switcher and indicator.
Diffstat (limited to 'russian/xruskb/Makefile')
-rw-r--r--russian/xruskb/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/russian/xruskb/Makefile b/russian/xruskb/Makefile
new file mode 100644
index 000000000000..110c529b76aa
--- /dev/null
+++ b/russian/xruskb/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xruskb
+# Version required: 1.7.0
+# Date created: 14 Jan 1998
+# Whom: Igor Vinokurov <igor@zynaps.ru>
+#
+# $Id$
+
+DISTNAME= xruskb-1.7.0
+CATEGORIES= russian x11
+MASTER_SITES= ftp://ftp.kiae.su/pub/x11/cyrillic/ \
+ ftp://ftp.yars.free.net/pub/software/unix/X11/
+
+MAINTAINER= igor@zynaps.ru
+
+USE_X_PREFIX= yes
+
+GNU_CONFIGURE= Yes
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/examples
+
+MAN1= xrus.1
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/Xrus.ad ${PREFIX}/lib/X11/app-defaults/Xrus
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/xruskb
+ ${INSTALL_DATA} ${WRKSRC}/xrus.doc-english ${PREFIX}/share/doc/xruskb
+ ${INSTALL_DATA} ${WRKSRC}/xrus.doc-koi8 ${PREFIX}/share/doc/xruskb
+.endif
+
+.include <bsd.port.mk>