aboutsummaryrefslogtreecommitdiffstats
path: root/science/2dhf/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-08-16 17:33:14 +0800
committermaho <maho@FreeBSD.org>2004-08-16 17:33:14 +0800
commita4d4761d9aaaa75f73d4d86221b0c9ecaafcaf46 (patch)
treec67d5b4eae369a7ca49bd966bdd605e08a116031 /science/2dhf/Makefile
parent1c1c98ed0f6331ee5dc37106fc0c50087353463b (diff)
downloadfreebsd-ports-gnome-a4d4761d9aaaa75f73d4d86221b0c9ecaafcaf46.tar.gz
freebsd-ports-gnome-a4d4761d9aaaa75f73d4d86221b0c9ecaafcaf46.tar.zst
freebsd-ports-gnome-a4d4761d9aaaa75f73d4d86221b0c9ecaafcaf46.zip
Add intel fortran/c/c++ compiler support
Diffstat (limited to 'science/2dhf/Makefile')
-rw-r--r--science/2dhf/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/science/2dhf/Makefile b/science/2dhf/Makefile
index ea08cf5cedb6..c4bfd66511ec 100644
--- a/science/2dhf/Makefile
+++ b/science/2dhf/Makefile
@@ -17,6 +17,10 @@ MAINTAINER= maho@FreeBSD.org
COMMENT= A Numerical Hartree-Fock Program for Diatomic Molecules
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+.if defined(USE_INTEL)
+BUILD_DEPENDS+= ${LOCALBASE}/intel_fc_80/bin/ifort:${PORTSDIR}/lang/ifc
+BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
+.endif
LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
atlas:${PORTSDIR}/math/atlas
@@ -27,6 +31,18 @@ FFLAGS+= -mfancy-math-387
.endif # i386
.endif
+BLAS= -lf77blas -latlas
+.if defined(USE_INTEL)
+FC= ${LOCALBASE}/intel_fc_80/bin/ifort
+CC= ${LOCALBASE}/intel_cc_80/bin/icc
+FFLAGS= -O3 -tpp7 -xiMKW -Vaxlib
+FFLAGS_ADD= -w -132
+CFLAGS= -O3 -tpp7 -xiMKW -Vaxlib
+BLAS+= -lg2c -lm
+.else
+FFLAGS_ADD= -w -ffixed-line-length-none
+.endif
+
pre-everything::
@${ECHO_CMD} "You can optimize by setting WITH_OPTIMIZED_FLAGS=yes."
@@ -41,9 +57,11 @@ do-extract:
post-patch:
@${REINPLACE_CMD} -e 's,%%FC%%,${FC},g ; \
s,%%FFLAGS%%,${FFLAGS},g ; \
+ s,%%FFLAGS_ADD%%,${FFLAGS_ADD},g ; \
s,%%CC%%,${CC},g ; \
s,%%CFLAGS%%,${CFLAGS},g ; \
- s,%%LOCALBASE%%,${LOCALBASE},g' \
+ s,%%LOCALBASE%%,${LOCALBASE},g ;\
+ s,%%BLAS%%,${BLAS},g' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/bin/xhf