aboutsummaryrefslogtreecommitdiffstats
path: root/science/InsightToolkit
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-12-19 17:58:02 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-12-19 17:58:02 +0800
commit25615223f8adf63fceebd7b0378de73a5169a742 (patch)
treed307cff2b5d0f818c4a996853a27c02c9dda6aee /science/InsightToolkit
parent5cf5ce09af6a7225f1228d3b1704c90db02b791f (diff)
downloadfreebsd-ports-gnome-25615223f8adf63fceebd7b0378de73a5169a742.tar.gz
freebsd-ports-gnome-25615223f8adf63fceebd7b0378de73a5169a742.tar.zst
freebsd-ports-gnome-25615223f8adf63fceebd7b0378de73a5169a742.zip
- Support staging
- Fix build on 10.x
Diffstat (limited to 'science/InsightToolkit')
-rw-r--r--science/InsightToolkit/Makefile27
-rw-r--r--science/InsightToolkit/files/patch-Code-Common-itkArray.h11
-rw-r--r--science/InsightToolkit/files/patch-Code-Common-itkArray2D.h11
-rw-r--r--science/InsightToolkit/files/patch-Code-Common-itkKLMSegmentationBorder.h33
-rw-r--r--science/InsightToolkit/files/patch-Code-Common-itkParametricPath.txx20
-rw-r--r--science/InsightToolkit/files/patch-Utilities-vxl-core-vnl-vnl__matrix__fixed__ref.h11
6 files changed, 94 insertions, 19 deletions
diff --git a/science/InsightToolkit/Makefile b/science/InsightToolkit/Makefile
index 194380e464d8..3253cbbe0eb4 100644
--- a/science/InsightToolkit/Makefile
+++ b/science/InsightToolkit/Makefile
@@ -10,35 +10,24 @@ MASTER_SITES= SF/itk/itk/2.8
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Insight Toolkit
-OPTIONS_DEFINE= EXAMPLES TESTING
-EXAMPLES_DESC= Build examples (very time consuming)
-TESTING_DESC= Build testing programs (very time consuming)
-
-USE_LDCONFIG= ${PREFIX}/lib/InsightToolkit
NO_PACKAGE= License does not allow redistribution of binaries
USES= cmake
CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON
+USE_LDCONFIG= ${PREFIX}/lib/InsightToolkit
SUB_FILES= pkg-message
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ! ${PORT_OPTIONS:MEXAMPLES}
-CMAKE_ARGS+= "-DBUILD_EXAMPLES:BOOL=OFF"
-.endif
+OPTIONS_DEFINE= EXAMPLES TESTING
+EXAMPLES_DESC= Build examples (very time consuming)
+TESTING_DESC= Build testing programs (very time consuming)
-.if ! ${PORT_OPTIONS:MTESTING}
-CMAKE_ARGS+= "-DBUILD_TESTING:BOOL=OFF"
-.endif
+EXAMPLES_CMAKE_OFF= -DBUILD_EXAMPLES:BOOL=OFF
+TESTING_CMAKE_OFF= -DBUILD_TESTING:BOOL=OFF
post-install:
- @for lib in ${PREFIX}/lib/InsightToolkit/*.so ; do \
+ @cd ${STAGEDIR}${PREFIX}/lib/InsightToolkit && for lib in *.so; do \
${LN} -s $$lib.2.8.0 $$lib.2 ; \
done
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/InsightToolkit/files/patch-Code-Common-itkArray.h b/science/InsightToolkit/files/patch-Code-Common-itkArray.h
new file mode 100644
index 000000000000..ced14ff2b69a
--- /dev/null
+++ b/science/InsightToolkit/files/patch-Code-Common-itkArray.h
@@ -0,0 +1,11 @@
+--- Code/Common/itkArray.h.orig 2006-03-16 14:43:26.000000000 +0300
++++ Code/Common/itkArray.h 2013-12-18 22:35:26.050168890 +0400
+@@ -78,7 +78,7 @@
+
+
+ /** Set the all the elements of the array to the specified value */
+- void Fill (TValueType const& v) { fill(v); }
++ void Fill (TValueType const& v) { this->fill(v); }
+
+ /** Copy opertor */
+ const Self & operator=( const Self &rhs );
diff --git a/science/InsightToolkit/files/patch-Code-Common-itkArray2D.h b/science/InsightToolkit/files/patch-Code-Common-itkArray2D.h
new file mode 100644
index 000000000000..31db56a8f237
--- /dev/null
+++ b/science/InsightToolkit/files/patch-Code-Common-itkArray2D.h
@@ -0,0 +1,11 @@
+--- Code/Common/itkArray2D.h.orig 2003-12-15 17:13:19.000000000 +0300
++++ Code/Common/itkArray2D.h 2013-12-18 22:35:49.297942916 +0400
+@@ -60,7 +60,7 @@
+ const Self & operator=( const Self & array );
+ const Self & operator=( const VnlMatrixType & matrix );
+
+- void Fill (TValueType const& v) { fill(v); }
++ void Fill (TValueType const& v) { this->fill(v); }
+
+ /** Destructively set the size to that given. Will lose data. */
+ void SetSize(unsigned int m, unsigned int n);
diff --git a/science/InsightToolkit/files/patch-Code-Common-itkKLMSegmentationBorder.h b/science/InsightToolkit/files/patch-Code-Common-itkKLMSegmentationBorder.h
new file mode 100644
index 000000000000..c9e401f96d7e
--- /dev/null
+++ b/science/InsightToolkit/files/patch-Code-Common-itkKLMSegmentationBorder.h
@@ -0,0 +1,33 @@
+--- Code/Common/itkKLMSegmentationBorder.h.orig 2006-02-07 01:01:56.000000000 +0300
++++ Code/Common/itkKLMSegmentationBorder.h 2013-12-17 17:28:09.961367612 +0400
+@@ -80,11 +80,11 @@
+
+ bool operator> (const KLMDynamicBorderArray<TBorder>* rhs) const
+ {
+- if( m_Pointer->GetLambda() == rhs.m_Pointer->GetLambda() )
++ if( m_Pointer->GetLambda() == rhs->m_Pointer->GetLambda() )
+ {
+ if( m_Pointer->GetLambda() < 0 )
+ {
+- return ( m_Pointer > rhs.m_Pointer );
++ return ( m_Pointer > rhs->m_Pointer );
+ }
+ else
+ {
+@@ -99,13 +99,13 @@
+ m_Pointer->GetRegion2()->GetRegionBorderSize() );
+
+ unsigned int v2 = vnl_math_max(
+- rhs.m_Pointer->GetRegion1()->GetRegionBorderSize(),
+- rhs.m_Pointer->GetRegion2()->GetRegionBorderSize() );
++ rhs->m_Pointer->GetRegion1()->GetRegionBorderSize(),
++ rhs->m_Pointer->GetRegion2()->GetRegionBorderSize() );
+
+ return ( v1 > v2 );
+ }
+ }
+- return(m_Pointer->GetLambda() > rhs.m_Pointer->GetLambda() );
++ return(m_Pointer->GetLambda() > rhs->m_Pointer->GetLambda() );
+ }
+
+ TBorder *m_Pointer;
diff --git a/science/InsightToolkit/files/patch-Code-Common-itkParametricPath.txx b/science/InsightToolkit/files/patch-Code-Common-itkParametricPath.txx
new file mode 100644
index 000000000000..e49bc985d053
--- /dev/null
+++ b/science/InsightToolkit/files/patch-Code-Common-itkParametricPath.txx
@@ -0,0 +1,20 @@
+--- Code/Common/itkParametricPath.txx.orig 2004-12-04 16:22:44.000000000 +0300
++++ Code/Common/itkParametricPath.txx 2013-12-18 22:34:31.538947309 +0400
+@@ -43,7 +43,7 @@
+ ContinuousIndexType continuousIndex;
+ IndexType index;
+
+- continuousIndex = Evaluate( input );
++ continuousIndex = this->Evaluate( input );
+
+ // Round each coordinate to the nearest integer value
+ for( unsigned int i=0; i<VDimension; i++ )
+@@ -136,7 +136,7 @@
+ inputStepSize = this->EndOfInput() - input;
+ }
+
+- return ( Evaluate(input + inputStepSize) - Evaluate(input) ) / inputStepSize;
++ return ( this->Evaluate(input + inputStepSize) - this->Evaluate(input) ) / inputStepSize;
+ }
+
+ template<unsigned int VDimension>
diff --git a/science/InsightToolkit/files/patch-Utilities-vxl-core-vnl-vnl__matrix__fixed__ref.h b/science/InsightToolkit/files/patch-Utilities-vxl-core-vnl-vnl__matrix__fixed__ref.h
new file mode 100644
index 000000000000..5020d0ef9c97
--- /dev/null
+++ b/science/InsightToolkit/files/patch-Utilities-vxl-core-vnl-vnl__matrix__fixed__ref.h
@@ -0,0 +1,11 @@
+--- Utilities/vxl/core/vnl/vnl_matrix_fixed_ref.h.orig 2006-03-22 01:25:06.000000000 +0300
++++ Utilities/vxl/core/vnl/vnl_matrix_fixed_ref.h 2013-12-17 17:21:57.529194289 +0400
+@@ -653,7 +653,7 @@
+ //: Return true if *this == rhs
+ bool operator_eq (vnl_matrix_fixed_ref_const<T,num_rows,num_cols> const & rhs) const
+ {
+- return equal( this->data_block(), rhs.data_block() );
++ return this->equal( this->data_block(), rhs.data_block() );
+ }
+
+ //: Equality operator