aboutsummaryrefslogtreecommitdiffstats
path: root/science/bft
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-06-18 05:04:54 +0800
committerthierry <thierry@FreeBSD.org>2007-06-18 05:04:54 +0800
commit89d68dcf18dc96251a46b660088aba9ad7bd6ded (patch)
treea65eee2fdacad780bcb85d290b3faa8e2d01aea0 /science/bft
parent66f5a5cce0cf0882a29d97cc4ad394fbc29031ce (diff)
downloadfreebsd-ports-gnome-89d68dcf18dc96251a46b660088aba9ad7bd6ded.tar.gz
freebsd-ports-gnome-89d68dcf18dc96251a46b660088aba9ad7bd6ded.tar.zst
freebsd-ports-gnome-89d68dcf18dc96251a46b660088aba9ad7bd6ded.zip
Code_Saturne is EDF's general purpose computational fluid dynamics
software. Developed since 1997 at EDF R&D, it is based on a co-located Finite Volume approach that accepts meshes with any type of cell (tetrahedral, hexahedral, prismatic, pyramidal, polyhedral, ...) and any type of grid structure (unstructured, blockstructured, hybrid, conforming or with hanging nodes, ...). Its basic capabilities enable the handling of either incompressible or expandable flows with or without heat transfer and turbulence (mixing length, 2-equation models, v2f, Reynolds stress models, Large Eddy Simulations, ...). <http://rd.edf.com/code_saturne/>
Diffstat (limited to 'science/bft')
-rw-r--r--science/bft/Makefile33
-rw-r--r--science/bft/distinfo3
-rw-r--r--science/bft/pkg-descr5
-rw-r--r--science/bft/pkg-plist18
4 files changed, 59 insertions, 0 deletions
diff --git a/science/bft/Makefile b/science/bft/Makefile
new file mode 100644
index 000000000000..f43e2a52055e
--- /dev/null
+++ b/science/bft/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: bft
+# Date created: Sun 1 apr 2007
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= bft
+PORTVERSION= 1.0.3
+CATEGORIES= science parallel
+MASTER_SITES= http://www.edf.fr/html/RetD/livraison_saturne_${REL_DATE}/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Code_Saturne Base Functions and Types library
+
+REL_DATE= 070305
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+TESTSBIN= bft_test
+
+pre-configure:
+ # No useful doc there
+ ${REINPLACE_CMD} -e 's|tests doc|tests|' ${WRKSRC}/Makefile.in
+
+regression-test:
+.for pg in ${TESTSBIN}
+ @(cd ${WRKSRC}/tests; ./${pg} arg1 arg2)
+.endfor
+
+.include <bsd.port.mk>
diff --git a/science/bft/distinfo b/science/bft/distinfo
new file mode 100644
index 000000000000..f75be4816a18
--- /dev/null
+++ b/science/bft/distinfo
@@ -0,0 +1,3 @@
+MD5 (bft-1.0.3.tar.gz) = 9003c7480df32b8f88fa95ee476244d7
+SHA256 (bft-1.0.3.tar.gz) = 92d96837e920fc4742d1a9058df0fd54c632ae2248304ff2e3976c2e74a754cf
+SIZE (bft-1.0.3.tar.gz) = 430826
diff --git a/science/bft/pkg-descr b/science/bft/pkg-descr
new file mode 100644
index 000000000000..d9dacf510b08
--- /dev/null
+++ b/science/bft/pkg-descr
@@ -0,0 +1,5 @@
+BFT stands for Base Functions and Types.
+It is destined to be used by scientific codes (CFD) often using
+some form of parallelism, especially MPI.
+
+WWW: http://rd.edf.com/code_saturne/
diff --git a/science/bft/pkg-plist b/science/bft/pkg-plist
new file mode 100644
index 000000000000..08eee58989c4
--- /dev/null
+++ b/science/bft/pkg-plist
@@ -0,0 +1,18 @@
+bin/bft-config
+include/bft_backtrace.h
+include/bft_config.h
+include/bft_config_priv.h
+include/bft_error.h
+include/bft_file.h
+include/bft_fp_trap.h
+include/bft_intl.h
+include/bft_mem.h
+include/bft_mem_usage.h
+include/bft_printf.h
+include/bft_sys_info.h
+include/bft_timer.h
+include/bft_version.h
+lib/libbft.a
+lib/libbft.la
+lib/libbft.so
+lib/libbft.so.1