aboutsummaryrefslogtreecommitdiffstats
path: root/science/brian/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-16 14:07:37 +0800
committermiwi <miwi@FreeBSD.org>2009-03-16 14:07:37 +0800
commit5d297b72f3b880be681e8e285514a7ce2a6a4bab (patch)
tree20b5ebfcda0111d8c21ef039f85b12e5478f5aeb /science/brian/Makefile
parentc7ab8e990a60da4864e342e94d289bbf43a00246 (diff)
downloadfreebsd-ports-gnome-5d297b72f3b880be681e8e285514a7ce2a6a4bab.tar.gz
freebsd-ports-gnome-5d297b72f3b880be681e8e285514a7ce2a6a4bab.tar.zst
freebsd-ports-gnome-5d297b72f3b880be681e8e285514a7ce2a6a4bab.zip
Brian is a simulator for spiking neural networks available on almost all
platforms. The motivation for this project is that a simulator should not only save the time of processors, but also the time of scientists. Brian is easy to learn and use, highly flexible and easily extensible. The Brian package itself and simulations using it are all written in the Python programming language, which is an easy, concise and highly developed language with many advanced features and development tools, excellent documentation and a large community of users providing support and extension packages. WWW: http://www.briansimulator.org/ PR: ports/132155 Submitted by: Wen Heping <wenheping@gmail.com>
Diffstat (limited to 'science/brian/Makefile')
-rw-r--r--science/brian/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/science/brian/Makefile b/science/brian/Makefile
new file mode 100644
index 000000000000..f78024406bd5
--- /dev/null
+++ b/science/brian/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: brian
+# Date created: 27 Feb, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= brian
+PORTVERSION= 1.1.2
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP \
+ SF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A clock-driven simulator for spiking neural networks
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.1.0:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.6.0:${PORTSDIR}/science/py-scipy \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_ZIP= yes
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>