aboutsummaryrefslogtreecommitdiffstats
path: root/science/cdo/files
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2007-04-10 11:09:55 +0800
committerlwhsu <lwhsu@FreeBSD.org>2007-04-10 11:09:55 +0800
commitc59b817325ed239dbd4b0937302bb8e58517efec (patch)
treeb04548ae167f087e28a027154cb1db7dddb905a0 /science/cdo/files
parent610212316137c208ffd9b26080fc421de324fd59 (diff)
downloadfreebsd-ports-gnome-c59b817325ed239dbd4b0937302bb8e58517efec.tar.gz
freebsd-ports-gnome-c59b817325ed239dbd4b0937302bb8e58517efec.tar.zst
freebsd-ports-gnome-c59b817325ed239dbd4b0937302bb8e58517efec.zip
- Update to 1.0.7
PR: 111346 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet AT sunpoet.net> (maintainer) Approved by: clsung (mentor)
Diffstat (limited to 'science/cdo/files')
-rw-r--r--science/cdo/files/patch-src-cdo_pthread.c6
-rw-r--r--science/cdo/files/patch-src-config.h.in17
-rw-r--r--science/cdo/files/patch-src-pthread_debug.c4
-rw-r--r--science/cdo/files/patch-src-pthread_debug.h4
4 files changed, 15 insertions, 16 deletions
diff --git a/science/cdo/files/patch-src-cdo_pthread.c b/science/cdo/files/patch-src-cdo_pthread.c
index 34cddbdf3abe..1a5c03102069 100644
--- a/science/cdo/files/patch-src-cdo_pthread.c
+++ b/science/cdo/files/patch-src-cdo_pthread.c
@@ -1,10 +1,10 @@
--- src/cdo_pthread.c.orig Wed Mar 22 22:04:18 2006
-+++ src/cdo_pthread.c Mon Dec 18 10:01:00 2006
++++ src/cdo_pthread.c Sat Apr 7 01:07:02 2007
@@ -32,8 +32,10 @@
{
#if defined (HAVE_LIBPTHREAD)
pthread_attr_t attr;
-+#if __FreeBSD_version >= 600000
++#if defined (PTHREAD_MUTEXATTR_CONDATTR)
pthread_mutexattr_t m_attr;
pthread_condattr_t c_attr;
+#endif
@@ -15,7 +15,7 @@
print_pthread_attr("Default pthread attr", &attr);
pthread_attr_destroy(&attr);
-+#if __FreeBSD_version >= 600000
++#if defined (PTHREAD_MUTEXATTR_CONDATTR)
pthread_mutexattr_init(&m_attr);
print_pthread_mutexattr("Default pthread mutexattr", &m_attr);
pthread_mutexattr_destroy(&m_attr);
diff --git a/science/cdo/files/patch-src-config.h.in b/science/cdo/files/patch-src-config.h.in
index 792cca69a62d..b4787e08098e 100644
--- a/science/cdo/files/patch-src-config.h.in
+++ b/science/cdo/files/patch-src-config.h.in
@@ -1,11 +1,10 @@
---- src/config.h.in.orig Wed Dec 13 21:30:19 2006
-+++ src/config.h.in Mon Dec 18 10:41:13 2006
-@@ -1,5 +1,8 @@
- /* src/config.h.in. Generated from configure.ac by autoheader. */
+--- src/config.h.in.orig Tue Dec 19 19:07:07 2006
++++ src/config.h.in Sat Apr 7 04:00:39 2007
+@@ -107,3 +107,7 @@
-+#include <unistd.h>
-+#include <sys/param.h>
+ /* Define for large files, on AIX-style hosts. */
+ #undef _LARGE_FILES
+
- /* Compiler */
- #undef COMPILER
-
++#if defined (HAVE_UNISTD_H)
++#include <unistd.h>
++#endif
diff --git a/science/cdo/files/patch-src-pthread_debug.c b/science/cdo/files/patch-src-pthread_debug.c
index accba3d44423..9aa0ad43b02f 100644
--- a/science/cdo/files/patch-src-pthread_debug.c
+++ b/science/cdo/files/patch-src-pthread_debug.c
@@ -1,10 +1,10 @@
--- src/pthread_debug.c.orig Mon Dec 4 16:11:40 2006
-+++ src/pthread_debug.c Mon Dec 18 10:01:00 2006
++++ src/pthread_debug.c Sat Apr 7 01:12:05 2007
@@ -77,6 +77,7 @@
}
-+#if __FreeBSD_version >= 600000
++#if defined (PTHREAD_MUTEXATTR_CONDATTR)
void print_pthread_mutexattr(const char *caller, pthread_mutexattr_t *m_attr)
{
int protocol, kind, pshared;
diff --git a/science/cdo/files/patch-src-pthread_debug.h b/science/cdo/files/patch-src-pthread_debug.h
index ac134fe9be35..c94e750bcc1f 100644
--- a/science/cdo/files/patch-src-pthread_debug.h
+++ b/science/cdo/files/patch-src-pthread_debug.h
@@ -1,10 +1,10 @@
--- src/pthread_debug.h.orig Wed Feb 15 21:22:38 2006
-+++ src/pthread_debug.h Mon Dec 18 10:01:00 2006
++++ src/pthread_debug.h Sat Apr 7 01:13:25 2007
@@ -15,8 +15,10 @@
void Pthread_cond_wait(const char *caller, pthread_cond_t *cond, pthread_mutex_t *mutex);
void print_pthread_attr(const char *caller, pthread_attr_t *attr);
-+#if __FreeBSD_version >= 600000
++#if defined (PTHREAD_MUTEXATTR_CONDATTR)
void print_pthread_mutexattr(const char *caller, pthread_mutexattr_t *m_attr);
void print_pthread_condattr(const char *caller, pthread_condattr_t *c_attr);
+#endif