aboutsummaryrefslogtreecommitdiffstats
path: root/science/chemtool-devel
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-10-04 10:25:28 +0800
committermaho <maho@FreeBSD.org>2003-10-04 10:25:28 +0800
commit0f2d8e38133cedf3a4d49ccc4fdfd98cd11756f4 (patch)
tree7356976350c26e94a7e3b829012c5b6f96c05223 /science/chemtool-devel
parent88e1f45243a49e938f7b1205ad5564963f51ba36 (diff)
downloadfreebsd-ports-gnome-0f2d8e38133cedf3a4d49ccc4fdfd98cd11756f4.tar.gz
freebsd-ports-gnome-0f2d8e38133cedf3a4d49ccc4fdfd98cd11756f4.tar.zst
freebsd-ports-gnome-0f2d8e38133cedf3a4d49ccc4fdfd98cd11756f4.zip
Update to up-to-date developer version
Many thanks to: Dr. Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
Diffstat (limited to 'science/chemtool-devel')
-rw-r--r--science/chemtool-devel/Makefile20
-rw-r--r--science/chemtool-devel/distinfo2
-rw-r--r--science/chemtool-devel/files/patch-Makefile.in20
3 files changed, 33 insertions, 9 deletions
diff --git a/science/chemtool-devel/Makefile b/science/chemtool-devel/Makefile
index 6ca47cfcdb10..cae93cd6c504 100644
--- a/science/chemtool-devel/Makefile
+++ b/science/chemtool-devel/Makefile
@@ -1,30 +1,34 @@
-# New ports collection makefile for: chemtool
-# Date created: Mar 5, 2003
+# New ports collection makefile for: chemtool-devel
+# Date created: Mar 5, 2003
# Whom: NAKATA, Maho <maho@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= chemtool
-PORTVERSION= 1.6
+PORTVERSION= 1.6.1
CATEGORIES= science
MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
-DISTNAME= ct16a29
+DISTNAME= ct161gtk2
EXTRACT_SUFX= .tgz
MAINTAINER= maho@FreeBSD.org
-COMMENT= Drawing organic molecules easily and store them (develop version)
+COMMENT= Drawing organic molecules easily and store them (developer version)
+LIB_DEPENDS= EMF.1:${PORTSDIR}/graphics/libemf
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}alpha29
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-gtk2/
USE_REINPLACE= yes
USE_GTK= yes
+USE_AUTOCONF= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+CONFIGURE_ARGS= --enable-emf=yes
+PKGNAMESUFFIX= -devel
MAN1= chemtool.1 cht.1
-do-build:
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE})
+post-patch:
+ ${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/Makefile.in
do-install:
@(cd ${WRKSRC}; ${GMAKE} install)
diff --git a/science/chemtool-devel/distinfo b/science/chemtool-devel/distinfo
index 9571e9dbae11..e23eaa29619b 100644
--- a/science/chemtool-devel/distinfo
+++ b/science/chemtool-devel/distinfo
@@ -1 +1 @@
-MD5 (ct16a29.tgz) = e6f3df2063e3bdb445269c3f61b8a65c
+MD5 (ct161gtk2.tgz) = 8f2c8b74dffee3021d5c24cc61372e90
diff --git a/science/chemtool-devel/files/patch-Makefile.in b/science/chemtool-devel/files/patch-Makefile.in
new file mode 100644
index 000000000000..192144e2a79d
--- /dev/null
+++ b/science/chemtool-devel/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Thu Aug 28 07:25:31 2003
++++ Makefile.in Sat Oct 4 11:16:42 2003
+@@ -5,7 +5,7 @@
+ mandir=@mandir@
+ kdedir=@kdemimedir@
+ gnomedir=@gnomemimedir@
+-CFLAGS=-O2 -Wall -Wunused -Wuninitialized -I. `gtk-config --cflags` @DEFS@ -DLOCALEDIR=\"${localedir}\"
++CFLAGS= @CFLAGS@ -I%%LOCALBASE%%/include -I%%LOCALBASE%%/include/libEMF -I. `gtk-config --cflags` @DEFS@ -DLOCALEDIR=\"${localedir}\"
+
+ CC=@CC@
+ CP=/bin/cp
+@@ -16,7 +16,7 @@
+ SRCS = main.c chemproc.c graph.c draw.c inout.c undo.c @MYGTKSRCS@
+ OBJS = main.o chemproc.o graph.o draw.o inout.o undo.o @MYGTKOBJS@
+
+-SYS_LIBRARIES = `gtk-config --libs` @EMFLIBS@ -lm
++SYS_LIBRARIES = `gtk-config --libs` -L%%LOCALBASE%%/lib @EMFLIBS@ -lm
+
+
+ all: chemtool cht