aboutsummaryrefslogtreecommitdiffstats
path: root/science/chemtool/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-07-21 08:57:58 +0800
committermaho <maho@FreeBSD.org>2003-07-21 08:57:58 +0800
commitb276ab723fb40aa8312d8a457bec54ca60ca7345 (patch)
tree60b06a996f5e37f4594265646d9f310b410bdc00 /science/chemtool/Makefile
parent3dea7e822cc5749c7d0f8ea2e805aa64e654852e (diff)
downloadfreebsd-ports-gnome-b276ab723fb40aa8312d8a457bec54ca60ca7345.tar.gz
freebsd-ports-gnome-b276ab723fb40aa8312d8a457bec54ca60ca7345.tar.zst
freebsd-ports-gnome-b276ab723fb40aa8312d8a457bec54ca60ca7345.zip
Update to 1.6 and some clean-up.
PR: 54664 Submitted by: KATO Tsuguru <tkato@prontomail.com> aka Ports fury
Diffstat (limited to 'science/chemtool/Makefile')
-rw-r--r--science/chemtool/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/science/chemtool/Makefile b/science/chemtool/Makefile
index 05f3b25c8d07..7ab9e4095aca 100644
--- a/science/chemtool/Makefile
+++ b/science/chemtool/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= chemtool
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= science
MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
@@ -15,13 +15,28 @@ COMMENT= Draw organic molecules easily and store them
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
USE_GNOME= gtk12
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= chemtool.1 cht.1
-post-install:
- ${MKDIR} ${PREFIX}/share/examples/chemtool
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/examples/chemtool
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/chemtool ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src-cht/cht ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/chemtool.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/cht.1 ${MANPREFIX}/man/man1
+.for lang in cs de fr pl pt_BR ru
+ @${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locales/${lang}/chemtool.mo \
+ ${PREFIX}/share/locale/${lang}/LC_MESSAGES
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${FIND} . | \
+ cpio -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>