aboutsummaryrefslogtreecommitdiffstats
path: root/science/ecs
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2012-07-07 23:15:56 +0800
committerthierry <thierry@FreeBSD.org>2012-07-07 23:15:56 +0800
commit8d118c7017be387768cac6f95dde7a629dc3b07f (patch)
treee0301a6724a81df51aa9ac6122ab1995d228c87f /science/ecs
parent80285e3bfae534dffa5b58222ebe3cddd9473051 (diff)
downloadfreebsd-ports-gnome-8d118c7017be387768cac6f95dde7a629dc3b07f.tar.gz
freebsd-ports-gnome-8d118c7017be387768cac6f95dde7a629dc3b07f.tar.zst
freebsd-ports-gnome-8d118c7017be387768cac6f95dde7a629dc3b07f.zip
Upgrade Code_Saturne to 2.0.
Diffstat (limited to 'science/ecs')
-rw-r--r--science/ecs/Makefile35
-rw-r--r--science/ecs/distinfo4
-rw-r--r--science/ecs/pkg-plist9
3 files changed, 33 insertions, 15 deletions
diff --git a/science/ecs/Makefile b/science/ecs/Makefile
index d1177ffcdfa7..883d4c0e2517 100644
--- a/science/ecs/Makefile
+++ b/science/ecs/Makefile
@@ -6,32 +6,43 @@
#
PORTNAME= ecs
-PORTVERSION= 1.3.3
-PORTREVISION= 7
+PORTVERSION= 2.0.2
CATEGORIES= science
-MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
+MASTER_SITES= http://research.edf.com/fichiers/fckeditor/Commun/Innovation/logiciels/code_saturne/Releases/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
-EXTRACT_SUFX= .tgz
MAINTAINER= thierry@FreeBSD.org
COMMENT= Code_Saturne Preprocessor
-LIB_DEPENDS= med.2:${PORTSDIR}/french/med \
+LICENSE= GPLv2
+
+LIB_DEPENDS= med.4:${PORTSDIR}/french/med \
bft.1:${PORTSDIR}/science/bft \
hdf5.7:${PORTSDIR}/science/hdf5-18 \
- cgns.0:${PORTSDIR}/science/cgnslib
+ cgns.3:${PORTSDIR}/science/cgnslib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_ZIP= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bft=${LOCALBASE} \
--with-hdf5=${LOCALBASE} \
--with-cgns=${LOCALBASE} \
--with-med=${LOCALBASE} \
- --with-metis=${LOCALBASE}
+ --with-metis=${LOCALBASE} \
+ --with-metis-include=${LOCALBASE}/include/metis
CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
USE_GMAKE= yes
+.if defined(WITH_CCMIO)
+LIB_DEPENDS+= adf.5:${PORTSDIR}/science/libccmio \
+ ccmio.2:${PORTSDIR}/science/libccmio
+CONFIGURE_ARGS+=--with-adf=${LOCALBASE} \
+ --with-ccm=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-adf --without-ccm
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
@@ -45,13 +56,14 @@ PLIST_SUB+= NLS=""
CONFIGURE_ARGS+= --enable-debug
.endif
-#NOPORTDOCS= yes # PDF not produced ATM
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= pdflatex:${PORTSDIR}/print/teTeX-base \
fig2dev:${PORTSDIR}/print/transfig
-PORTDOCS= mi_ecs.pdf mu_ecs.pdf
+PORTDOCS= mi_ecs.pdf mt_ecs.pdf
.endif
+MAN1= cs_io_dump.1 cs_partition.1 cs_preprocess-config.1 cs_preprocess.1
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/bin/partdmesh)
@@ -62,6 +74,11 @@ LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis-edf
.endif
+.if ${ARCH} == "i386"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libscotch.a:${PORTSDIR}/cad/scotch
+CONFIGURE_ARGS+= --with-scotch=${LOCALBASE}
+.endif
+
pre-configure:
.if !defined(NOPORTDOCS)
${REINPLACE_CMD} -e '/^SUBDIRS/s| po| po doc|' ${WRKSRC}/Makefile.in
diff --git a/science/ecs/distinfo b/science/ecs/distinfo
index f053dd6e145c..0e6be81e8978 100644
--- a/science/ecs/distinfo
+++ b/science/ecs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ecs-133.tgz) = 60c3519cc7b9fdd80f41844e3c5a04be88459493e6abd82ed960304822d1bf13
-SIZE (ecs-133.tgz) = 1263592
+SHA256 (ecs-202.zip) = 237712e1df2bb1a7a479407ebf325c5ebb89ccaf29d86e9f52f52907677f23a2
+SIZE (ecs-202.zip) = 1369458
diff --git a/science/ecs/pkg-plist b/science/ecs/pkg-plist
index ff4ad28c07d6..d65322b5e807 100644
--- a/science/ecs/pkg-plist
+++ b/science/ecs/pkg-plist
@@ -1,4 +1,5 @@
-bin/ecs
-bin/ecs-config
-bin/perm_nopo
-%%NLS%%share/locale/fr/LC_MESSAGES/ecs.mo
+bin/cs_preprocess-config
+bin/cs_preprocess
+bin/cs_partition
+bin/cs_io_dump
+%%NLS%%share/locale/fr/LC_MESSAGES/cs_preprocess.mo