aboutsummaryrefslogtreecommitdiffstats
path: root/science/elmerpost/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
committerrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
commitc8007265d81e778bec43e1f7b073b196887b3604 (patch)
treea30fd3dc7b50670b88ce6f8cf28e0ccf2b1e599a /science/elmerpost/Makefile
parent9f3176cd391ec72812d7f37e93b881faa3648b45 (diff)
downloadfreebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.gz
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.zst
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Diffstat (limited to 'science/elmerpost/Makefile')
-rw-r--r--science/elmerpost/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/science/elmerpost/Makefile b/science/elmerpost/Makefile
index 3ec4606c0961..6049d5ae1598 100644
--- a/science/elmerpost/Makefile
+++ b/science/elmerpost/Makefile
@@ -7,7 +7,7 @@
PORTNAME= elmerpost
PORTVERSION= 5.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= SF/elmerfem
@@ -30,8 +30,6 @@ ALL_TARGET=
USE_FORTRAN= yes
CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS=${FCFLAGS}
-PLIST_SUB= ARCH=${MACHINE_ARCH}
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"