aboutsummaryrefslogtreecommitdiffstats
path: root/science/fastcap/Makefile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-08-20 19:28:54 +0800
committerbf <bf@FreeBSD.org>2011-08-20 19:28:54 +0800
commit291e19a4769028bf807c9fd9fbaadce26bf3249a (patch)
treeb7cb988543484a2d2c8141d650f2d1b74e42a0b8 /science/fastcap/Makefile
parent354a332817dcc1d1ddd7e28032ba57a88e8f7c46 (diff)
downloadfreebsd-ports-gnome-291e19a4769028bf807c9fd9fbaadce26bf3249a.tar.gz
freebsd-ports-gnome-291e19a4769028bf807c9fd9fbaadce26bf3249a.tar.zst
freebsd-ports-gnome-291e19a4769028bf807c9fd9fbaadce26bf3249a.zip
fix the clang build
Diffstat (limited to 'science/fastcap/Makefile')
-rw-r--r--science/fastcap/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/science/fastcap/Makefile b/science/fastcap/Makefile
index c4d547f794cb..34051281d94a 100644
--- a/science/fastcap/Makefile
+++ b/science/fastcap/Makefile
@@ -22,8 +22,17 @@ BINFILES= busgen capgen cubegen fastcap pipedgen pyragen
post-patch:
@${REINPLACE_CMD} -e 's,TYPE=other,TYPE=4,' \
${WRKSRC}/config
- @${REINPLACE_CMD} -e 's,CFLAGS =,CFLAGS +=,' \
+ @${REINPLACE_CMD} -Ee '/CFLAGS =/{s/=/+=/;s/-O[[:digit:]]*//;}' \
${WRKSRC}/src/Makefile.4
+#minimal changes to fix the clang build (there should be a more thorough
+#clean-up, to correct types of functions, remove implicit declarations, fix
+#formatting, add missing returns, etc.)
+ @${REINPLACE_CMD} -E -e 's,^mul(Up|Down),void &,' \
+ ${WRKSRC}/src/mulDo.c
+ @${REINPLACE_CMD} -e 's,^mulMatUp,void &,' \
+ ${WRKSRC}/src/mulMats.c
+ @${REINPLACE_CMD} -e 's,^static getnbrs,static void getnbrs,' \
+ ${WRKSRC}/src/mulSetup.c
do-install:
.for b in ${BINFILES}