aboutsummaryrefslogtreecommitdiffstats
path: root/science/flounder
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /science/flounder
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'science/flounder')
-rw-r--r--science/flounder/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/flounder/Makefile b/science/flounder/Makefile
index 9405c0280dbd..6b71f83ef247 100644
--- a/science/flounder/Makefile
+++ b/science/flounder/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
USE_GL= glut
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lstdc++"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lstdc++
USE_GMAKE= yes
.if !defined(WITHOUT_PLOT)