aboutsummaryrefslogtreecommitdiffstats
path: root/science/fvcom
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-07-28 03:14:43 +0800
committerwg <wg@FreeBSD.org>2014-07-28 03:14:43 +0800
commita663dab0550f9b7b659176f02fd17d78219a104a (patch)
tree68a14dd1fd55c2323d197eae86e99b360ea7b772 /science/fvcom
parentb730c1b3a3af4510d1f5e1db8905e5348cc8b567 (diff)
downloadfreebsd-ports-gnome-a663dab0550f9b7b659176f02fd17d78219a104a.tar.gz
freebsd-ports-gnome-a663dab0550f9b7b659176f02fd17d78219a104a.tar.zst
freebsd-ports-gnome-a663dab0550f9b7b659176f02fd17d78219a104a.zip
science/fvcom: fix for LEGAL and correct install for mpi version
- Pass back maintaienrship (user had an open PR) PR: 189091 Submitted by: maintainer
Diffstat (limited to 'science/fvcom')
-rw-r--r--science/fvcom/Makefile18
-rw-r--r--science/fvcom/files/patch-mod_lag.F2
-rw-r--r--science/fvcom/pkg-message4
3 files changed, 19 insertions, 5 deletions
diff --git a/science/fvcom/Makefile b/science/fvcom/Makefile
index 7e26b8c149cc..109bd6843401 100644
--- a/science/fvcom/Makefile
+++ b/science/fvcom/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://fvcom.smast.umassd.edu/FVCOM/index.html/
DISTNAME= sourcecode1
DIST_SUBDIR= fvcom
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jwbacon@tds.net
COMMENT= Unstructured Grid Finite Volume Coastal Ocean Model
# Check netcdf lib for Fortran support!
@@ -18,11 +18,12 @@ LIB_DEPENDS+= libnetcdff.so:${PORTSDIR}/science/netcdf-fortran \
libblas.so:${PORTSDIR}/math/lapack
USES= fortran
+USE_GCC= yes
WRKSRC= ${WRKDIR}/FVCOM2.7.1/FVCOM_source
-PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}
+PLIST_FILES= ${MPIPREFIX}bin/${PORTNAME}${PKGNAMESUFFIX}
-RESTRICTED= may not be redistributed because of licensing reasons
+RESTRICTED= Requires (free) registration
.include <bsd.port.pre.mk>
@@ -33,14 +34,23 @@ IGNORE= may not be redistributed because of licensing reasons.\
and place it in ${DISTDIR}/${DIST_SUBDIR}/
.endif
+MAKE_JOBS_UNSAFE= yes
+
post-extract:
${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
+post-patch:
+ ${REINPLACE_CMD} -e 's|gcc|${CC}|g' \
+ ${WRKDIR}/FVCOM2.7.1/METIS_source/makefile
+ ${REINPLACE_CMD} -e 's|cpp|${CPP}|g' \
+ ${WRKDIR}/FVCOM2.7.1/FVCOM_source/Makefile
+
pre-build:
(cd ${WRKSRC}/../METIS_source && make)
do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${MPIPREFIX}bin
${INSTALL_PROGRAM} ${WRKSRC}/fvcom \
- ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
+ ${STAGEDIR}${PREFIX}/${MPIPREFIX}bin/${PORTNAME}${PKGNAMESUFFIX}
.include <bsd.port.post.mk>
diff --git a/science/fvcom/files/patch-mod_lag.F b/science/fvcom/files/patch-mod_lag.F
index 84377bb00b64..47bb78aee0bd 100644
--- a/science/fvcom/files/patch-mod_lag.F
+++ b/science/fvcom/files/patch-mod_lag.F
@@ -1,5 +1,5 @@
--- mod_lag.F.orig 2008-07-25 16:44:11.000000000 -0500
-+++ mod_lag.F 2012-03-31 21:57:17.000000000 -0500
++++ mod_lag.F 2014-04-28 12:23:34.000000000 -0500
@@ -212,7 +212,12 @@
!Lagrangian particle associated scalar
character(len=80) :: lag_scal_choice
diff --git a/science/fvcom/pkg-message b/science/fvcom/pkg-message
new file mode 100644
index 000000000000..b0b5ea4c3fa2
--- /dev/null
+++ b/science/fvcom/pkg-message
@@ -0,0 +1,4 @@
+-----------------------------------------------------------------------
+FVCOM has many build options that can be used in combination. To build
+other variants, use one of the slave ports science/fvcom-*.
+-----------------------------------------------------------------------