aboutsummaryrefslogtreecommitdiffstats
path: root/science/fvm/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2009-11-28 18:44:56 +0800
committerthierry <thierry@FreeBSD.org>2009-11-28 18:44:56 +0800
commit821dbba052a0ebd1ff69db896a7e5af7c9a21fd9 (patch)
tree83ed04ecf451d9c7a671e32f6ad037860245534a /science/fvm/Makefile
parent6156d85b8e504b4e5ea95a6e25e7d34c0e31fde6 (diff)
downloadfreebsd-ports-gnome-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.tar.gz
freebsd-ports-gnome-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.tar.zst
freebsd-ports-gnome-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.zip
- Chase relocation of net/mpich2
- Bump PORTREVISION if needed - Fix some portlint errors.
Diffstat (limited to 'science/fvm/Makefile')
-rw-r--r--science/fvm/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
index 246a9b7d0164..9c539f5a1115 100644
--- a/science/fvm/Makefile
+++ b/science/fvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fvm
PORTVERSION= 0.12.0
+PORTREVISION= 1
CATEGORIES= science parallel
MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -39,9 +40,9 @@ BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}/mpi/openmpi
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
-CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}
.endif
.if defined(WITH_DEBUG)