aboutsummaryrefslogtreecommitdiffstats
path: root/science/fvm/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-03-27 07:29:28 +0800
committerthierry <thierry@FreeBSD.org>2014-03-27 07:29:28 +0800
commit8a4296e61d641be4e83041ff1fa0ddedd009accc (patch)
tree7d535271fce1acc0b942478acb6f2956d7d3bc0c /science/fvm/Makefile
parentc8cee74eeb6439b1ad8a1551e53ce570f98e98d6 (diff)
downloadfreebsd-ports-gnome-8a4296e61d641be4e83041ff1fa0ddedd009accc.tar.gz
freebsd-ports-gnome-8a4296e61d641be4e83041ff1fa0ddedd009accc.tar.zst
freebsd-ports-gnome-8a4296e61d641be4e83041ff1fa0ddedd009accc.zip
- Unbreak Code_Saturne;
- Adapt to the new infrastructure. Note: these ports should be upgraded - this is on my todo list.
Diffstat (limited to 'science/fvm/Makefile')
-rw-r--r--science/fvm/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
index 8c644ccdfc79..ae9ff12745a1 100644
--- a/science/fvm/Makefile
+++ b/science/fvm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fvm
PORTVERSION= 0.15.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science parallel
MASTER_SITES= http://research.edf.com/fichiers/fckeditor/Commun/Innovation/logiciels/code_saturne/Releases/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -13,10 +13,10 @@ COMMENT= Code_Saturne Finite Volume Mesh
LICENSE= LGPL21
-LIB_DEPENDS= med.5:${PORTSDIR}/french/med \
- bft.1:${PORTSDIR}/science/bft \
- hdf5.7:${PORTSDIR}/science/hdf5-18 \
- cgns.3:${PORTSDIR}/science/cgnslib
+LIB_DEPENDS= libmed.so:${PORTSDIR}/french/med \
+ libbft.so:${PORTSDIR}/science/bft \
+ libhdf5.so.7:${PORTSDIR}/science/hdf5-18\
+ libcgns.so:${PORTSDIR}/science/cgnslib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -47,11 +47,8 @@ CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}
CONFIGURE_ARGS+= --enable-debug
.endif
-MAN1= fvm-config.1
-
TESTSBIN= fvm_file_test fvm_interface_test fvm_selector_postfix_test fvm_selector_test
-NO_STAGE= yes
pre-configure:
${REINPLACE_CMD} -e 's|-lmpich|-lmpich -lmpl|' \
${WRKSRC}/${CONFIGURE_SCRIPT}