aboutsummaryrefslogtreecommitdiffstats
path: root/science/gamess/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-05-08 14:08:44 +0800
committermaho <maho@FreeBSD.org>2009-05-08 14:08:44 +0800
commit21947beb714ba231140527b2d2ffa59893473865 (patch)
tree4c5d9dafd953edd3fb43fa2f9bf7394cf33497bf /science/gamess/Makefile
parent089bfbc8953327cae77ba9d73b842332c5a77dd2 (diff)
downloadfreebsd-ports-gnome-21947beb714ba231140527b2d2ffa59893473865.tar.gz
freebsd-ports-gnome-21947beb714ba231140527b2d2ffa59893473865.tar.zst
freebsd-ports-gnome-21947beb714ba231140527b2d2ffa59893473865.zip
Update to 20090112 R1 version.
Diffstat (limited to 'science/gamess/Makefile')
-rw-r--r--science/gamess/Makefile32
1 files changed, 23 insertions, 9 deletions
diff --git a/science/gamess/Makefile b/science/gamess/Makefile
index e61ee5421b7a..bb96df00d894 100644
--- a/science/gamess/Makefile
+++ b/science/gamess/Makefile
@@ -7,7 +7,6 @@
PORTNAME= gamess
PORTVERSION= ${SNAPDATE}
-PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= #http://www.msg.ameslab.gov/GAMESS/License_Agreement.html
DISTNAME= gamess-current
@@ -18,7 +17,7 @@ COMMENT= A freely obtainable ab-initio molecular orbital calculation program
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/gamess
-SNAPDATE= 20070524.3
+SNAPDATE= 20090112.1
USE_FORTRAN= yes
@@ -33,17 +32,32 @@ MANUAL_PACKAGE_BUILD=You must manually get the source distribution from master s
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
+USE_BLAS?= reference
+
+.if exists(${LOCALBASE}/lib/libgoto.so)
+USE_BLAS= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas_r.so)
+USE_BLAS= atlas
.endif
-.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas
-.else
+
+. if ${USE_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
+LAPACK= -llapack
+.elif ${USE_BLAS} == gotoblas
+LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+BLAS= -lgotop
+LAPACK= -lgotop -llapack
+.elif ${USE_BLAS} == atlas
+LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+BLAS= -lptf77blas -lptcblas -latlas_r
+LAPACK= -lalapack_r
.endif
+MAKE_ENV+= LANG="C"
+
.if defined(WITH_OPTIMIZED_FLAGS)
.if ${ARCH} == "amd64"
CFLAGS+= -pipe -O3 -ffast-math -funroll-all-loops -fpeel-loops -ftracer -funswitch-loops -funit-at-a-time
@@ -62,7 +76,7 @@ CC= ${LOCALBASE}/intel_cc_80/bin/icc
FFLAGS= -axP -xW -ipo -O3 -Vaxlib
CFLAGS= -axP -xW -ipo -O3 -Vaxlib
LIBSVM= -lsvml
-LIBG2C= -lg2c
+LIBG2C= -lg2c
.else
LIBG2C=
LIBSVM=