aboutsummaryrefslogtreecommitdiffstats
path: root/science/gamess
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2010-02-16 13:51:43 +0800
committermaho <maho@FreeBSD.org>2010-02-16 13:51:43 +0800
commit5b6447e57ae11e62f79b9df35938172fc7732153 (patch)
tree25973c4abda6013e5d71599ecb011c394175800b /science/gamess
parente966189c8d3d667cf671f638e0f329377cfbe00d (diff)
downloadfreebsd-ports-gnome-5b6447e57ae11e62f79b9df35938172fc7732153.tar.gz
freebsd-ports-gnome-5b6447e57ae11e62f79b9df35938172fc7732153.tar.zst
freebsd-ports-gnome-5b6447e57ae11e62f79b9df35938172fc7732153.zip
Fix build with recent update of gotoblas(2).
Feature safe: yes
Diffstat (limited to 'science/gamess')
-rw-r--r--science/gamess/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/science/gamess/Makefile b/science/gamess/Makefile
index e0de4eda7577..f08eec449944 100644
--- a/science/gamess/Makefile
+++ b/science/gamess/Makefile
@@ -34,7 +34,7 @@ MANUAL_PACKAGE_BUILD=You must manually get the source distribution from master s
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -46,10 +46,9 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -lgotop
-LAPACK= -lgotop -llapack
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+BLAS= -lgoto2p
+LAPACK= -lgoto2p
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r