aboutsummaryrefslogtreecommitdiffstats
path: root/science/gchemutils/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-27 06:21:20 +0800
committerpav <pav@FreeBSD.org>2006-05-27 06:21:20 +0800
commit32062d25b2bef57d1ff9ca177cb6450c4f9ba0eb (patch)
tree0a6cd0a77427d6f25b390a058b0c1196df071160 /science/gchemutils/Makefile
parent37e49f653fef9c7f0722802075983ef526b27aa2 (diff)
downloadfreebsd-ports-gnome-32062d25b2bef57d1ff9ca177cb6450c4f9ba0eb.tar.gz
freebsd-ports-gnome-32062d25b2bef57d1ff9ca177cb6450c4f9ba0eb.tar.zst
freebsd-ports-gnome-32062d25b2bef57d1ff9ca177cb6450c4f9ba0eb.zip
- Support Mozilla plugin
Diffstat (limited to 'science/gchemutils/Makefile')
-rw-r--r--science/gchemutils/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/science/gchemutils/Makefile b/science/gchemutils/Makefile
index 50bfcf302704..ba04ba92eac1 100644
--- a/science/gchemutils/Makefile
+++ b/science/gchemutils/Makefile
@@ -26,8 +26,20 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+OPTIONS= MOZILLA "Build mozilla plugin" off
+
.include <bsd.port.pre.mk>
+.if defined(WITH_MOZILLA)
+USE_GECKO= mozilla
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+CONFIGURE_ARGS+=--enable-mozilla-plugin
+PLIST_SUB= MOZILLA=""
+.else
+CONFIGURE_ARGS+=--disable-mozilla-plugin
+PLIST_SUB= MOZILLA="@comment "
+.endif
+
.if ${OSVERSION} < 500000
BROKEN= does not link with openbabel
.endif