aboutsummaryrefslogtreecommitdiffstats
path: root/science/ghemical/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-05-04 10:33:52 +0800
committermaho <maho@FreeBSD.org>2003-05-04 10:33:52 +0800
commit9eab6d8db25c83bd01ec72fe6fe0ddc3e1f6c026 (patch)
tree57409c25e0c65a4b1d23b4ff31145bf155ab5f88 /science/ghemical/Makefile
parent25c1a134d6a3a5ebdcffd36f95104a741a2b604c (diff)
downloadfreebsd-ports-gnome-9eab6d8db25c83bd01ec72fe6fe0ddc3e1f6c026.tar.gz
freebsd-ports-gnome-9eab6d8db25c83bd01ec72fe6fe0ddc3e1f6c026.tar.zst
freebsd-ports-gnome-9eab6d8db25c83bd01ec72fe6fe0ddc3e1f6c026.zip
Add new port science/ghemical
a computational chemistry software package
Diffstat (limited to 'science/ghemical/Makefile')
-rw-r--r--science/ghemical/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/science/ghemical/Makefile b/science/ghemical/Makefile
new file mode 100644
index 000000000000..c0bc8e4a52b9
--- /dev/null
+++ b/science/ghemical/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ghemical
+# Date created: May 4, 2003
+# Whom: Nakata Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= ghemical
+PORTVERSION= 1.00
+CATEGORIES= science
+MASTER_SITES= http://www.uku.fi/~thassine/ghemical/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= Ghemical is a computational chemistry software package
+
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+ ${LOCALBASE}/lib/libmpqc.a:${PORTSDIR}/science/mpqc
+LIB_DEPENDS= gtkgl:${PORTSDIR}/x11-toolkits/gtkglarea \
+ glade-gnome:${PORTSDIR}/devel/libglade
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-mpqc
+
+USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 253
+
+pre-configure:
+ @cd ${WRKDIR}/${DISTNAME} ; ${AUTOCONF}
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g;' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g; s|-lgtk|-lgtk12|g;' \
+ ${WRKSRC}/Makefile.in
+pre-build:
+ @${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/miniMOPAC/*.c
+ @${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/src/common/qm1e_mopac.cpp
+.include <bsd.port.mk>