aboutsummaryrefslogtreecommitdiffstats
path: root/science/glens
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-09-20 14:32:12 +0800
committerijliao <ijliao@FreeBSD.org>2002-09-20 14:32:12 +0800
commit16cdbbf3e8f72401712c16958b7880b62a2e01fe (patch)
tree4d3c02215371a8b1ab87d0d6e771abf5b4d5513a /science/glens
parent701dbe8cbbcb86f99b1e9169741e31d37bf69e14 (diff)
downloadfreebsd-ports-gnome-16cdbbf3e8f72401712c16958b7880b62a2e01fe.tar.gz
freebsd-ports-gnome-16cdbbf3e8f72401712c16958b7880b62a2e01fe.tar.zst
freebsd-ports-gnome-16cdbbf3e8f72401712c16958b7880b62a2e01fe.zip
- Support CFLAGS/CXXFLAGS properly
- Support install macros PR: 42892 Submitted by: Ports Fury
Diffstat (limited to 'science/glens')
-rw-r--r--science/glens/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/science/glens/Makefile b/science/glens/Makefile
index 6915b5ea101d..75b29d011291 100644
--- a/science/glens/Makefile
+++ b/science/glens/Makefile
@@ -8,6 +8,7 @@
PORTNAME= glens
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://virtual.theo.phys.ulg.ac.be/
@@ -15,16 +16,22 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${X11BASE}/lib/libglui.a:${PORTSDIR}/devel/glui
+USE_REINPLACE= yes
USE_MESA= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -lstdc++"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-glui=${X11BASE}
-.if !defined(NOPORTDOCS)
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+
+post-patch:
+ @${REINPLACE_CMD} 's|-O6||g' ${WRKSRC}/configure
+
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/cfg ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}/cfg
+ ${INSTALL_DATA} ${WRKSRC}/cfg/*.cgf ${EXAMPLESDIR}/cfg
.endif
.include <bsd.port.mk>