aboutsummaryrefslogtreecommitdiffstats
path: root/science/hdf-java
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-06-20 21:25:04 +0800
committerbsam <bsam@FreeBSD.org>2013-06-20 21:25:04 +0800
commite9ac310c6ae518aee7aaef3bb5120281feee6c22 (patch)
tree3a710cef2d870c8ae97826db2121bae828597884 /science/hdf-java
parentc1322d54a9d846f2f8276d57fc88e664ff3fad61 (diff)
downloadfreebsd-ports-gnome-e9ac310c6ae518aee7aaef3bb5120281feee6c22.tar.gz
freebsd-ports-gnome-e9ac310c6ae518aee7aaef3bb5120281feee6c22.tar.zst
freebsd-ports-gnome-e9ac310c6ae518aee7aaef3bb5120281feee6c22.zip
. remove shlib ABI version numbers from LIB_DEPENDS;
. add USE_LDCONFIG (portlint: installing shared libraries); . mute mkdir at install command.
Diffstat (limited to 'science/hdf-java')
-rw-r--r--science/hdf-java/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/science/hdf-java/Makefile b/science/hdf-java/Makefile
index 9a09ed826bef..962072abd57e 100644
--- a/science/hdf-java/Makefile
+++ b/science/hdf-java/Makefile
@@ -11,8 +11,8 @@ EXTRACT_SUFX= -src.tar
MAINTAINER= ports@FreeBSD.org
COMMENT= Java interface to HDF5
-LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18 \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= hdf5:${PORTSDIR}/science/hdf5-18 \
+ jpeg:${PORTSDIR}/graphics/jpeg
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -30,6 +30,7 @@ CONFIGURE_ARGS= --with-jdk=${JAVA_HOME}/include,${JAVA_HOME}/jre/lib/ \
--with-libjpeg=${LOCALBASE} \
--without-hdf4 \
--without-h4toh5
+USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -65,7 +66,7 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/UsersGuide
+ @${MKDIR} ${DOCSDIR}/UsersGuide
(cd ${WRKSRC}/docs/hdfview/ && ${COPYTREE_SHARE} "UsersGuide" ${DOCSDIR}/)
(cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} "javadocs" ${DOCSDIR}/)
.endif