aboutsummaryrefslogtreecommitdiffstats
path: root/science/hdf/files
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2012-04-22 02:07:21 +0800
committermi <mi@FreeBSD.org>2012-04-22 02:07:21 +0800
commit9fada4158076769c8ee1c86de7bc1bec6121c482 (patch)
tree6443f12cb3a8f9a0b035f526cecd8beb0d303429 /science/hdf/files
parent427b882ad7e06eab131a7ad66dd8457ad5b106f1 (diff)
downloadfreebsd-ports-gnome-9fada4158076769c8ee1c86de7bc1bec6121c482.tar.gz
freebsd-ports-gnome-9fada4158076769c8ee1c86de7bc1bec6121c482.tar.zst
freebsd-ports-gnome-9fada4158076769c8ee1c86de7bc1bec6121c482.zip
Upgrade from 4.2r3 to 4.2.7 (this neccessitated EPOCH bump).
Unbreak, untangle. Stop fetching/installing documents (other than man-pages) -- these are available online. Using standard libtool instead of the bundled one fails -- an autotools expert should take a closer look.
Diffstat (limited to 'science/hdf/files')
-rw-r--r--science/hdf/files/patch-compile-flags41
-rw-r--r--science/hdf/files/patch-lib-versions31
-rw-r--r--science/hdf/files/patch-shared-fortran31
3 files changed, 103 insertions, 0 deletions
diff --git a/science/hdf/files/patch-compile-flags b/science/hdf/files/patch-compile-flags
new file mode 100644
index 000000000000..de3bb33cbf5f
--- /dev/null
+++ b/science/hdf/files/patch-compile-flags
@@ -0,0 +1,41 @@
+Don't append optimization flags -- rely on what the building
+machine has set.
+--- config/freebsd 2012-03-17 23:44:05.000000000 -0400
++++ config/freebsd 2012-04-21 10:30:43.000000000 -0400
+@@ -102,5 +102,5 @@
+ DEBUG_CFLAGS="-g -ansi -Wall -pedantic "
+ DEBUG_CPPFLAGS=
+- PROD_CFLAGS="-ansi -Wall -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wmissing-prototypes -Wnested-externs -pedantic -O2"
++ PROD_CFLAGS="-ansi -Wall -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wmissing-prototypes -Wnested-externs -pedantic"
+ PROD_CPPFLAGS=
+ PROFILE_CFLAGS="-pg"
+@@ -112,5 +112,4 @@
+ DEBUG_CFLAGS="-g"
+ DEBUG_CPPFLAGS=
+- PROD_CFLAGS="-O"
+ PROD_CPPFLAGS=
+ PROFILE_CFLAGS="-pg"
+@@ -123,5 +122,4 @@
+ FFLAGS="$FFLAGS"
+ DEBUG_FFLAGS="-g"
+- PROD_FFLAGS="-O"
+ PROFILE_FFLAGS="-pg"
+ ;;
+@@ -130,5 +128,4 @@
+ FFLAGS="$FFLAGS"
+ DEBUG_FFLAGS="-g"
+- PROD_FFLAGS="-O"
+ PROFILE_FFLAGS="-pg"
+ ;;
+@@ -139,5 +136,4 @@
+ CXXFLAGS="$CXXFLAGS"
+ DEBUG_CXXFLAGS="-g -fverbose-asm"
+- PROD_CXXFLAGS="-O3 -fomit-frame-pointer"
+ PROFILE_CXXFLAGS="-pg"
+ ;;
+@@ -146,5 +142,4 @@
+ CXXFLAGS="$CXXFLAGS -ansi"
+ DEBUG_CXXFLAGS="-g"
+- PROD_CXXFLAGS="-O"
+ PROFILE_CXXFLAGS="-pg"
+ ;;
diff --git a/science/hdf/files/patch-lib-versions b/science/hdf/files/patch-lib-versions
new file mode 100644
index 000000000000..2cd9010049dd
--- /dev/null
+++ b/science/hdf/files/patch-lib-versions
@@ -0,0 +1,31 @@
+--- hdf/src/Makefile.in 2012-03-17 23:45:49.000000000 -0400
++++ hdf/src/Makefile.in 2012-04-21 13:33:36.000000000 -0400
+@@ -188,5 +188,5 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LD = @LD@
+-LDFLAGS = @LDFLAGS@
++LDFLAGS = @LDFLAGS@ -version-number 2
+ LEX = @LEX@
+ LIBOBJS = @LIBOBJS@
+@@ -291,6 +291,4 @@
+ H4CC = $(bindir)/h4cc
+ H4FC = $(bindir)/h4fc
+-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
+-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
+ ACLOCAL_AMFLAGS = "-I m4"
+ lib_LTLIBRARIES = libdf.la
++++ mfhdf/libsrc/Makefile.in 2012-04-21 13:33:36.000000000 -0400
+@@ -188,5 +188,5 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LD = @LD@
+-LDFLAGS = @LDFLAGS@
++LDFLAGS = @LDFLAGS@ -version-number 3
+ LEX = @LEX@
+ LIBOBJS = @LIBOBJS@
+@@ -291,6 +291,4 @@
+ H4CC = $(bindir)/h4cc
+ H4FC = $(bindir)/h4fc
+-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
+-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
+ ACLOCAL_AMFLAGS = "-I m4"
+ lib_LTLIBRARIES = libdf.la
diff --git a/science/hdf/files/patch-shared-fortran b/science/hdf/files/patch-shared-fortran
new file mode 100644
index 000000000000..c353819946de
--- /dev/null
+++ b/science/hdf/files/patch-shared-fortran
@@ -0,0 +1,31 @@
+--- configure.ac 2012-03-17 23:45:46.000000000 -0400
++++ configure.ac 2012-04-21 10:01:41.000000000 -0400
+@@ -199,6 +199,5 @@
+ dnl -------------------------------------------------------------------------
+ dnl Build static libraries by default. Furthermore, fortran shared libraries
+-dnl are unsupported. Disallow a user from enabling both shared libraries and
+-dnl fortran.
++dnl are unsupported.
+ if test "X${enable_shared}" != "Xyes"; then
+ enable_shared="no"
+@@ -207,5 +206,5 @@
+ if test "X${enable_shared}" = "Xyes"; then
+ if test "X${BUILD_FORTRAN}" = "Xyes"; then
+- AC_MSG_ERROR([Cannot build shared fortran libraries. Please configure with --disable-fortran flag.])
++ AC_MSG_WARN([Fortran shared libraries aren't supported.])
+ fi
+ fi
+--- configure 2012-03-17 23:45:51.000000000 -0400
++++ configure 2012-04-21 09:51:08.000000000 -0400
+@@ -5838,11 +5838,4 @@
+ fi
+
+-if test "X${enable_shared}" = "Xyes"; then
+- if test "X${BUILD_FORTRAN}" = "Xyes"; then
+- as_fn_error $? "Cannot build shared fortran libraries. Please configure with --disable-fortran flag." "$LINENO" 5
+- fi
+-fi
+-
+-
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ln -s works" >&5
+ $as_echo_n "checking whether ln -s works... " >&6; }