aboutsummaryrefslogtreecommitdiffstats
path: root/science/hdf5-18/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-11-03 20:10:43 +0800
committertg <tg@FreeBSD.org>1997-11-03 20:10:43 +0800
commitc6010d616542bed224ce112469e824d25c6e0f11 (patch)
tree01093759f786db45d52523d2e0b1ee525fb8eb8e /science/hdf5-18/Makefile
parente116acc8bf0a3f1cfae3d06c3f32746d4809f7de (diff)
downloadfreebsd-ports-gnome-c6010d616542bed224ce112469e824d25c6e0f11.tar.gz
freebsd-ports-gnome-c6010d616542bed224ce112469e824d25c6e0f11.tar.zst
freebsd-ports-gnome-c6010d616542bed224ce112469e824d25c6e0f11.zip
Import HDF port. HDF is yet another graphics format.
PR: 4546 Submitted by: Mikhail Teterin <mi@aldan.ziplink.net>
Diffstat (limited to 'science/hdf5-18/Makefile')
-rw-r--r--science/hdf5-18/Makefile68
1 files changed, 68 insertions, 0 deletions
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
new file mode 100644
index 000000000000..934cfc344b4a
--- /dev/null
+++ b/science/hdf5-18/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: HDF_lib
+# Version required: 4.1r1
+# Date created: 17 November 1996
+# Whom: mi
+#
+# $Id$
+#
+
+DISTNAME= HDF4.1r1
+PKGNAME= hdf-4.1r1
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.ncsa.uiuc.edu/HDF/HDF_Current/tar/
+
+MAINTAINER= mi@aldan.ziplink.net
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+
+GNU_CONFIGURE= yes
+MAKE_FLAGS= CC="$(CC)" -f
+
+# This will create dummy Makefiles and some links in the jpeg and libz
+# subdirectories. This way, we do not need to hunt all the dependencies
+# out. Shame on the lib's developers, though, this can not be done through
+# `configure'. -mi
+pre-build:
+ test -d ${WRKSRC}/hdf/jpeg.came-with-HDF || \
+ ${MV} -f ${WRKSRC}/hdf/jpeg ${WRKSRC}/hdf/jpeg.came-with-HDF
+ -${MKDIR} ${WRKSRC}/hdf/jpeg
+ ${RM} -f ${WRKSRC}/hdf/jpeg/Makefile
+ ${ECHO} #Phony makefile > ${WRKSRC}/hdf/jpeg/Makefile
+ ${ECHO} >> ${WRKSRC}/hdf/jpeg/Makefile
+ ${ECHO} libjpeg.a: >> ${WRKSRC}/hdf/jpeg/Makefile
+ printf '\t@echo Using the already installed JPEG library\n' \
+ >> ${WRKSRC}/hdf/jpeg/Makefile
+ printf '\nclean:\n\ttrue\n' >> ${WRKSRC}/hdf/jpeg/Makefile
+ printf '\ninstall-lib:\n\ttrue\n' >> ${WRKSRC}/hdf/jpeg/Makefile
+ printf '\ninstall:\n\ttrue\n' >> ${WRKSRC}/hdf/jpeg/Makefile
+ -ln -s ${PREFIX}/lib/libjpeg* ${WRKSRC}/hdf/jpeg/
+ -ln -s ${PREFIX}/include/j*.h ${WRKSRC}/hdf/jpeg/
+ test -d ${WRKSRC}/hdf/zlib.came-with-HDF || \
+ ${MV} -f ${WRKSRC}/hdf/zlib ${WRKSRC}/hdf/zlib.came-with-HDF
+ -${MKDIR} ${WRKSRC}/hdf/zlib
+ ${RM} -f ${WRKSRC}/hdf/zlib/Makefile
+ ${ECHO} #Phony makefile > ${WRKSRC}/hdf/zlib/Makefile
+ ${ECHO} >> ${WRKSRC}/hdf/zlib/Makefile
+ ${ECHO} libzlib.a: >> ${WRKSRC}/hdf/zlib/Makefile
+ printf '\t@echo Using the already installed ZLIB library\n' \
+ >> ${WRKSRC}/hdf/zlib/Makefile
+ printf '\nclean:\n\ttrue\n' >> ${WRKSRC}/hdf/zlib/Makefile
+ printf '\ninstall-lib:\n\ttrue\n' >> ${WRKSRC}/hdf/zlib/Makefile
+ printf '\ninstall:\n\ttrue\n' >> ${WRKSRC}/hdf/zlib/Makefile
+ -ln -s /usr/lib/libz* ${WRKSRC}/hdf/zlib/
+ -ln -s /usr/include/zconf.h /usr/include/zlib.h ${WRKSRC}/hdf/zlib/
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @for man_page in `grep man./ ${PKGDIR}/PLIST` ; do \
+ mp=`echo $${man_page} | ${SED} s/\.gz//` ;\
+ ${ECHO} Compressing ${PREFIX}/$$mp ;\
+ ${GZIP_CMD} ${PREFIX}/$$mp ; done
+.endif
+ @for binary in `grep ^bin/ ${PKGDIR}/PLIST` ; do strip ${PREFIX}/$$binary; done
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+test:
+ cd ${WRKSRC}; make $@
+
+.include <bsd.port.mk>