aboutsummaryrefslogtreecommitdiffstats
path: root/science/libghemical/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-11-05 17:16:08 +0800
committermaho <maho@FreeBSD.org>2009-11-05 17:16:08 +0800
commitd3419d3a3d1389f38790a0e0e1f0caf1a1f98565 (patch)
tree0087aaf9945ee47aed9c52dcc91bcdc3354b3cba /science/libghemical/Makefile
parented143dece25845d9db2f1c69ada1840fee8bfd13 (diff)
downloadfreebsd-ports-gnome-d3419d3a3d1389f38790a0e0e1f0caf1a1f98565.tar.gz
freebsd-ports-gnome-d3419d3a3d1389f38790a0e0e1f0caf1a1f98565.tar.zst
freebsd-ports-gnome-d3419d3a3d1389f38790a0e0e1f0caf1a1f98565.zip
Update to 2.99.1 and unbreak.
Feature safe: yes
Diffstat (limited to 'science/libghemical/Makefile')
-rw-r--r--science/libghemical/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index 52bcfb7b7a8d..36873f19fc98 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -5,10 +5,9 @@
# $FreeBSD$
PORTNAME= libghemical
-PORTVERSION= 2.98
-PORTREVISION= 3
+PORTVERSION= 2.99.1
CATEGORIES= science
-MASTER_SITES= http://www.uku.fi/~thassine/projects/download/release20080731/ \
+MASTER_SITES= http://www.uku.fi/~thassine/projects/download/release20090911/ \
http://bioinformatics.org/ghemical/download/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -16,7 +15,9 @@ MAINTAINER= maho@FreeBSD.org
COMMENT= Support libraries of science/ghemical port
BUILD_DEPENDS= openbabel:${PORTSDIR}/science/openbabel \
- mopac7:${PORTSDIR}/biology/mopac
+ mopac7:${PORTSDIR}/biology/mopac \
+ intltool-update:${PORTSDIR}/textproc/intltool \
+ ld:${PORTSDIR}/devel/binutils
LIB_DEPENDS+= mpqc:${PORTSDIR}/science/mpqc \
f2c:${PORTSDIR}/lang/f2c
@@ -26,16 +27,15 @@ USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
USE_FORTRAN= yes
-USE_AUTOTOOLS= autoconf:262
-CONFIGURE_ARGS+= --enable-mpqc --enable-openbabel --enable-mopac7
-
+USE_AUTOTOOLS= autoconf:262 libtool:22 automake:110
+CONFIGURE_ARGS+= --enable-mpqc
PLIST_SUB= LIBGHEMICAL_VERSION="${PORTVERSION}"
-.if ${OSVERSION} >= 700000
-BROKEN= does not configure
-.endif
+.include <bsd.port.pre.mk>
+
+pre-build:
+ ${RM} -f ${WRKSRC}/libtool
+ ${LN} -sf ${LIBTOOL} ${WRKSRC}/libtool
.include <bsd.port.post.mk>