aboutsummaryrefslogtreecommitdiffstats
path: root/science/libghemical
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-09-25 19:04:02 +0800
committermarino <marino@FreeBSD.org>2014-09-25 19:04:02 +0800
commit8858214fcbe80e7199b996909d65e93b7b8fb92c (patch)
tree06166b9765b1b84ad5ba7d0fa10a61c076a5a467 /science/libghemical
parenta0caa364cbb9dd1ebbc1939cf1a0ac3b5fa90f9a (diff)
downloadfreebsd-ports-gnome-8858214fcbe80e7199b996909d65e93b7b8fb92c.tar.gz
freebsd-ports-gnome-8858214fcbe80e7199b996909d65e93b7b8fb92c.tar.zst
freebsd-ports-gnome-8858214fcbe80e7199b996909d65e93b7b8fb92c.zip
science: Fix mpqc, libint and unbreak ghemical, and libghemical atomically
science/ghemical would not link because libghemical.so (from science/ libghemical port) had never been properly linked. Links to all mpqc "SC" libraries were added to LDFLAGS to rectify this. The configure breakage and solution is described below. After the version of lang/gcc was bumped from 4.7 to 4.8, science/libghemical ceased to configure and it was marked broken. After recreating the conftest, it was discovered that two versions incompatible versions of libgcc_s.so were getting pulled in by the realtime linker: the base version and the gcc48 ports version. The base version was getting pulled in by science/libint. To unbreak libghemical, libint is now built with lang/gcc. It was necessary to force libtool to link with LDFLAGS that Mk/bsd.gcc.mk sets so that the runpaths match across libraries used by libghemical. When science/mpqc was staged, it utilized libtool which renumbered all the library versions from 8.0.1 to 7.1.0. This was caused by the age component being greater than 0. By patching configure.in with a new version, we can generate major SHLIB of 8 again. While here, fix the bin/sc-config tool to remove a bad include cflag. With this fixes, science/ghemical builds successfully. Bump all 4 of these ports, remove any BROKEN designation and remove redundant @dirrm in pkg-plist
Diffstat (limited to 'science/libghemical')
-rw-r--r--science/libghemical/Makefile12
-rw-r--r--science/libghemical/pkg-plist11
2 files changed, 8 insertions, 15 deletions
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index 19c715ccafbf..f6ba58cbbe14 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libghemical
PORTVERSION= 3.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science
MASTER_SITES= http://bioinformatics.org/ghemical/download/release20111012/ \
http://bioinformatics.org/ghemical/download/current
@@ -11,8 +11,6 @@ MASTER_SITES= http://bioinformatics.org/ghemical/download/release20111012/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Support libraries of science/ghemical port
-BROKEN= Fails to configure
-
BUILD_DEPENDS= obabel:${PORTSDIR}/science/openbabel \
intltool-update:${PORTSDIR}/textproc/intltool \
ld:${PORTSDIR}/devel/binutils
@@ -26,7 +24,13 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS+= --enable-mpqc
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS= -L${LOCALBASE}/lib -lSCbasis -lSCcints -lSCclass \
+ -lSCcontainer -lSCdft -lSCgroup -lSCintv3 -lSCisosurf \
+ -lSCkeyval -lSCmbpt -lSCmbptr12 -lSCmisc -lSCmolecule \
+ -lSCoint3 -lSCoptimize -lSCoptions -lSCpsi -lSCref \
+ -lSCrender -lSCscf -lSCscmat -lSCsolvent -lSCstate \
+ -lSCsymmetry -lSCwfn \
+ -lgfortran -lpthread -lblas -llapack
PLIST_SUB= LIBGHEMICAL_VERSION="${PORTVERSION}"
INSTALL_TARGET= install-strip
diff --git a/science/libghemical/pkg-plist b/science/libghemical/pkg-plist
index ea89ef59fc04..8239250ef4df 100644
--- a/science/libghemical/pkg-plist
+++ b/science/libghemical/pkg-plist
@@ -36,7 +36,6 @@ include/ghemical/typedef.h
include/ghemical/typerule.h
include/ghemical/utility.h
include/ghemical/v3d.h
-@dirrm include/ghemical
lib/libghemical.so.5.0.1
lib/libghemical.so.5
lib/libghemical.so
@@ -74,13 +73,3 @@ share/locale/mk/LC_MESSAGES/libghemical.mo
share/locale/pt_BR/LC_MESSAGES/libghemical.mo
share/locale/ru/LC_MESSAGES/libghemical.mo
share/locale/sq/LC_MESSAGES/libghemical.mo
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/prmfit
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/default
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/amber
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/builder
-@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%
-@dirrm share/libghemical