aboutsummaryrefslogtreecommitdiffstats
path: root/science/massxpert/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-05-20 17:43:14 +0800
committerwen <wen@FreeBSD.org>2010-05-20 17:43:14 +0800
commit701e73004ce4b27022c61581491a3413dbd93fab (patch)
tree459ded9f3bf02c884da9455de0b105d2bfce069c /science/massxpert/Makefile
parent8e05933ab8650cfdba1fe5af02ab3136cd5c2d94 (diff)
downloadfreebsd-ports-gnome-701e73004ce4b27022c61581491a3413dbd93fab.tar.gz
freebsd-ports-gnome-701e73004ce4b27022c61581491a3413dbd93fab.tar.zst
freebsd-ports-gnome-701e73004ce4b27022c61581491a3413dbd93fab.zip
The massXpert project aims at providing (bio)chemists with a software
package allowing the following: * User-specific atom definitions and polymer chemistry definitions; * Powerful sequence editing with user-defined glyphs for each monomer and monomer chemical modification. Multi-region selections; * Polymer sequence chemical/enzymatic cleavage; * Intramolecular cross-linking, like disulfide bonds with total resolution of the peptides generated upon enzymatic cleavage; * Gas-phase fragmentation of oligomers; * Mass-to-charge ratio calculations with inline change of ionization agent; * Calculation of net electrical charge and of isoelectric point (even by taking into account monomer modifications if polymer is a protein); * Simulation of isotopic patterns for any chemical formula and z charge; * A number of plugins allow 1) translation of the sequence from one format to another (using a dictionary, like between the 1-letter code and the 3-letter code of proteins) 2) conversion of number format according to any localized number format 3) sort mass lists. PR: ports/146564 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Diffstat (limited to 'science/massxpert/Makefile')
-rw-r--r--science/massxpert/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
new file mode 100644
index 000000000000..869fa6cb7c50
--- /dev/null
+++ b/science/massxpert/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: massxpert
+# Date created: 2010-05-14
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= massxpert
+PORTVERSION= 2.3.6
+CATEGORIES= science
+MASTER_SITES= http://download.tuxfamily.org/massxpert/source/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= The massXpert software for (bio)chemists
+
+USE_QT_VER= 4
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+QT_COMPONENTS= gui xml rcc_build qmake_build uic_build moc_build \
+ svg
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+CMAKE_USE_PTHREAD= yes
+.endif
+
+.include <bsd.port.post.mk>