aboutsummaryrefslogtreecommitdiffstats
path: root/science/mbdyn
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-07-05 23:50:43 +0800
committerultima <ultima@FreeBSD.org>2017-07-05 23:50:43 +0800
commitbee0a57958f149c587a25de6cb228dbda4488ba5 (patch)
tree55ec92825d768f8b2876937579b35385d341ef4c /science/mbdyn
parent20aff0a5d075559c6ea89d1a4be2a4bec48ee87c (diff)
downloadfreebsd-ports-gnome-bee0a57958f149c587a25de6cb228dbda4488ba5.tar.gz
freebsd-ports-gnome-bee0a57958f149c587a25de6cb228dbda4488ba5.tar.zst
freebsd-ports-gnome-bee0a57958f149c587a25de6cb228dbda4488ba5.zip
* Updated to 1.7.2
* New maintainer Jov <amutu@amutu.com> * Sorted options Changelog: https://www.mbdyn.org/userfiles/downloads/CHANGELOG-1.7.txt PR: 220157 Submitted by: Jov <amutu@amutu.com> (maintainer), pfg Reviewed by: matthew (mentor), matt Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D11481
Diffstat (limited to 'science/mbdyn')
-rw-r--r--science/mbdyn/Makefile65
-rw-r--r--science/mbdyn/distinfo6
-rw-r--r--science/mbdyn/files/patch-include__ac__mpi.h11
-rw-r--r--science/mbdyn/files/patch-mbdyn__base__invsolver.cc12
-rw-r--r--science/mbdyn/files/patch-mbdyn__base__solver.cc42
-rw-r--r--science/mbdyn/files/patch-mbdyn__mbdyn.h18
6 files changed, 26 insertions, 128 deletions
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 9f542e367ed4..543f675615e4 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -2,82 +2,63 @@
# $FreeBSD$
PORTNAME= mbdyn
-PORTVERSION= 1.7.1
-PORTREVISION= 2
+PORTVERSION= 1.7.2
CATEGORIES= science
MASTER_SITES= https://www.mbdyn.org/userfiles/downloads/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amutu@amutu.com
COMMENT= MultiBody Dynamics analysis system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc= Does not compile on powerpc
+
+BUILD_DEPENDS= libatomic_ops>0:devel/libatomic_ops
LIB_DEPENDS= libltdl.so:devel/libltdl \
libarpack.so:math/arpack \
libumfpack.so:math/suitesparse
-BROKEN_powerpc= Does not compile on powerpc
-
GNU_CONFIGURE= yes
-USES= compiler:c++11-lib fortran gmake libtool localbase
+USES= compiler:c++11-lib fortran gmake libtool:build localbase
USE_LDCONFIG= yes
CPPFLAGS+= -fpermissive -I${LOCALBASE}/include/suitesparse
-CONFIGURE_ARGS+= --program-prefix=''
+CONFIGURE_ARGS= --program-prefix='' --enable-multithread --with-mpi=no \
+ --with-ginac=no
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= MPI METIS CHACO GINAC
+OPTIONS_DEFINE= METIS CHACO
OPTIONS_RADIO= BLAS
OPTIONS_RADIO_BLAS= REFERENCE GOTOBLAS ATLAS
OPTIONS_DEFAULT= REFERENCE
-REFERENCE_DESC= Blas / Lapack
-REFERENCE_USES= blaslapack:netlib
-REFERENCE_CONFIGURE_ON= --with-blas=blas
-
ATLAS_DESC= ATLAS
-ATLAS_USES= blaslapack:atlas
-ATLAS_CONFIGURE_ON= --with-blas=atlas
-
+CHACO_DESC= Enable chaco-support
GOTOBLAS_DESC= GotoBLAS2
-GOTOBLAS_USES= blaslapack:gotoblas
-GOTOBLAS_CONFIGURE_ON= --with-blas=goto --with-goto=goto2
-
-MPI_DESC= Enable mpich-support (Requires Metis or Chaco, broken)
-MPI_IGNORE= you enabled MPI support, which is broken
-MPI_BUILD_DEPENDS_OFF= libatomic_ops>0:devel/libatomic_ops
-MPI_LIB_DEPENDS= libmpich.so:net/mpich2
-MPI_CONFIGURE_ON= --with-mpi=yes --enable-schur
-MPI_CONFIGURE_OFF= --with-mpi=no --enable-multithread
+METIS_DESC= Enable metis-support
+REFERENCE_DESC= Blas / Lapack
-METIS_DESC= Enable metis-support
-METIS_LIB_DEPENDS= libmetis.so:math/metis4
-METIS_CONFIGURE_ON= --with-metis=yes
-METIS_CPPFLAGS= -I${LOCALBASE}/include/metis
-METIS_CONFIGURE_OFF= --with-metis=no
+ATLAS_CONFIGURE_ON= --with-blas=atlas
+ATLAS_USES= blaslapack:atlas
-CHACO_DESC= Enable chaco-support
CHACO_BUILD_DEPENDS= ${LOCALBASE}/lib/libchaco.a:math/chaco
CHACO_CONFIGURE_ON= --with-chaco=yes
CHACO_CONFIGURE_OFF= --with-chaco=no
-GINAC_DESC= Enable GiNaC-support (not implemented yet)
-GINAC_IGNORE= you enabled GiNaC-support, which is broken
-GINAC_LIB_DEPENDS= libmetis.so:math/metis4 \
- libginac.so:math/GiNaC
-GINAC_CONFIGURE_ON= --with-ginac=yes
-GINAC_CONFIGURE_OFF= --with-ginac=no
-GINAC_CPPFLAGS= -I${LOCALBASE}/include/metis
+GOTOBLAS_CONFIGURE_ON= --with-blas=goto --with-goto=goto2
+GOTOBLAS_USES= blaslapack:gotoblas
-.include <bsd.port.pre.mk>
+METIS_CONFIGURE_ON= --with-metis=yes
+METIS_CONFIGURE_OFF= --with-metis=no
+METIS_CPPFLAGS= -I${LOCALBASE}/include/metis
+METIS_LIB_DEPENDS= libmetis.so:math/metis4
-.if ${PORT_OPTIONS:MMPI} && ! ${PORT_OPTIONS:MMETIS}
-WITH_CHACO= yes
-.endif
+REFERENCE_CONFIGURE_ON= --with-blas=blas
+REFERENCE_USES= blaslapack:netlib
pre-configure:
${REINPLACE_CMD} -e '/try_lapack_LIBS=/s/-llapack/${LAPACKLIB}/' \
-e 's/ -lxerbla//; s/-lcholmod/-lcholmod ${BLASLIB} ${LAPACKLIB} -lsuitesparseconfig/' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/mbdyn/distinfo b/science/mbdyn/distinfo
index 0906a63e1405..83925c503378 100644
--- a/science/mbdyn/distinfo
+++ b/science/mbdyn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473272629
-SHA256 (mbdyn-1.7.1.tar.gz) = 2c1f21a6459c58103778cb5d771fc49f972baaa57866329ecd1e90dcf04b4ccf
-SIZE (mbdyn-1.7.1.tar.gz) = 2834562
+TIMESTAMP = 1497778371
+SHA256 (mbdyn-1.7.2.tar.gz) = 383977c988ce0a3ebb40ecc62cae8a6276bf42f1aa34e80bd9f2f78d792cd4ff
+SIZE (mbdyn-1.7.2.tar.gz) = 2915000
diff --git a/science/mbdyn/files/patch-include__ac__mpi.h b/science/mbdyn/files/patch-include__ac__mpi.h
deleted file mode 100644
index c8a3f0ea276c..000000000000
--- a/science/mbdyn/files/patch-include__ac__mpi.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/ac/mpi.h.orig 2015-10-30 05:05:33 UTC
-+++ include/ac/mpi.h
-@@ -35,7 +35,7 @@
- #ifdef HAVE_MPI___H
- #include <mpi++.h>
- #elif defined HAVE_MPICXX_H
--#include <mpicxx.h>
-+#include <mpi.h>
- #endif /* ! HAVE_MPI___H && ! HAVE_MPICXX_H */
-
- #endif /* MPI_H */
diff --git a/science/mbdyn/files/patch-mbdyn__base__invsolver.cc b/science/mbdyn/files/patch-mbdyn__base__invsolver.cc
deleted file mode 100644
index 654d1aa20952..000000000000
--- a/science/mbdyn/files/patch-mbdyn__base__invsolver.cc
+++ /dev/null
@@ -1,12 +0,0 @@
---- mbdyn/base/invsolver.cc.orig 2016-04-24 19:10:43 UTC
-+++ mbdyn/base/invsolver.cc
-@@ -114,8 +114,8 @@ InverseSolver::Prepare(void)
- pRTSolver->Setup();
- }
-
--#ifdef USE_SCHUR
- int mpi_finalize = 0;
-+#ifdef USE_SCHUR
-
- if (bParallel) {
- DEBUGLCOUT(MYDEBUG_MEM, "creating parallel SchurDataManager"
diff --git a/science/mbdyn/files/patch-mbdyn__base__solver.cc b/science/mbdyn/files/patch-mbdyn__base__solver.cc
deleted file mode 100644
index f0111db3cb60..000000000000
--- a/science/mbdyn/files/patch-mbdyn__base__solver.cc
+++ /dev/null
@@ -1,42 +0,0 @@
---- mbdyn/base/solver.cc.orig 2016-04-24 19:10:43 UTC
-+++ mbdyn/base/solver.cc
-@@ -109,10 +109,17 @@ enum {
- };
-
- volatile sig_atomic_t mbdyn_keep_going = MBDYN_KEEP_GOING;
-+#if defined(__FreeBSD__)
-+__sighandler_t *mbdyn_sh_term = SIG_DFL;
-+__sighandler_t *mbdyn_sh_int = SIG_DFL;
-+__sighandler_t *mbdyn_sh_hup = SIG_DFL;
-+__sighandler_t *mbdyn_sh_pipe = SIG_DFL;
-+#else
- __sighandler_t mbdyn_sh_term = SIG_DFL;
- __sighandler_t mbdyn_sh_int = SIG_DFL;
- __sighandler_t mbdyn_sh_hup = SIG_DFL;
- __sighandler_t mbdyn_sh_pipe = SIG_DFL;
-+#endif
-
- extern "C" void
- mbdyn_really_exit_handler(int signum)
-@@ -200,7 +207,11 @@ extern "C" void
- mbdyn_signal_init(int pre)
- {
- #ifdef HAVE_SIGNAL
-+#if defined(__FreeBSD__)
-+ __sighandler_t *hdl;
-+#else
- __sighandler_t hdl;
-+#endif
- if (pre) {
- hdl = mbdyn_really_exit_handler;
-
-@@ -406,8 +417,8 @@ Solver::Prepare(void)
- pRTSolver->Setup();
- }
-
--#ifdef USE_SCHUR
- int mpi_finalize = 0;
-+#ifdef USE_SCHUR
-
- if (bParallel) {
- DEBUGLCOUT(MYDEBUG_MEM, "creating parallel SchurDataManager"
diff --git a/science/mbdyn/files/patch-mbdyn__mbdyn.h b/science/mbdyn/files/patch-mbdyn__mbdyn.h
deleted file mode 100644
index 2690e9070f7b..000000000000
--- a/science/mbdyn/files/patch-mbdyn__mbdyn.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- mbdyn/mbdyn.h.orig 2015-10-30 05:05:37 UTC
-+++ mbdyn/mbdyn.h
-@@ -50,6 +50,7 @@ typedef long int Lint;
- typedef double Real;
-
- /* signal types */
-+#if !defined(__FreeBSD__)
- #ifdef HAVE_SIGNAL
- #ifndef HAVE___SIGHANDLER_T
- #ifndef HAVE_SIGHANDLER_T
-@@ -59,6 +60,7 @@ typedef sighandler_t __sighandler_t;
- #endif /* HAVE_SIGHANDLER_T */
- #endif /* !HAVE___SIGHANDLER_T */
- #endif /* HAVE_SIGNAL */
-+#endif
-
- /* sig_atomic_t */
- #ifndef HAVE_SIG_ATOMIC_T