aboutsummaryrefslogtreecommitdiffstats
path: root/science/mbdyn
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-11-22 19:14:10 +0800
committerbf <bf@FreeBSD.org>2011-11-22 19:14:10 +0800
commite76c3137d0dc704cf66c758a906a5be85b715a3b (patch)
tree5df944d34b65ba2c3cbfa92e36a81489e70a8220 /science/mbdyn
parent79f1897cd8102cd7c050b91f5ec19e049be5fb80 (diff)
downloadfreebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.tar.gz
freebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.tar.zst
freebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.zip
adjust linking and comments in dependent ports after the math/atlas update;
math/atlas-devel will be updated to use the same constructs at a later date PR: 162706 Approved by: miwi (portmgr) Feature safe: yes
Diffstat (limited to 'science/mbdyn')
-rw-r--r--science/mbdyn/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index ecb24eb999cb..87b4f36fe46d 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -38,18 +38,18 @@ OPTIONS= MPI "Enable mpich-support" off \
BROKEN= Does not compile on powerpc
.endif
-USE_BLAS?= reference
+WITH_BLAS?= reference
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas \
lapack.4:${PORTSDIR}/math/lapack
CONFIGURE_ARGS+= --with-blas=blas
LAPACK_LIBS= -llapack
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
CONFIGURE_ARGS+= --with-blas=goto --with-goto=goto2
LAPACK_LIBS= -lgoto2
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
CONFIGURE_ARGS+= --with-blas=atlas
LAPACK_LIBS= -lalapack