aboutsummaryrefslogtreecommitdiffstats
path: root/science/medit/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-09-25 07:09:26 +0800
committerthierry <thierry@FreeBSD.org>2006-09-25 07:09:26 +0800
commit9b0e7890d93dfad33831dcd5a32c02b4c9002e10 (patch)
tree332eb6b9411038d4017a33af8362ce779e95b538 /science/medit/Makefile
parentc8bd57b6d117a2d21708db97cb014e2a08341964 (diff)
downloadfreebsd-ports-gnome-9b0e7890d93dfad33831dcd5a32c02b4c9002e10.tar.gz
freebsd-ports-gnome-9b0e7890d93dfad33831dcd5a32c02b4c9002e10.tar.zst
freebsd-ports-gnome-9b0e7890d93dfad33831dcd5a32c02b4c9002e10.zip
Medit is an interactive mesh visualization software, developed by the Gamma
project at INRIA-Rocquencourt. It is intended to display computation results (in mechanics of the solids or fluids, thermics, electromagnetism, etc.) on grids 2d (triangles and quadrangles), 3d (tetrahedrons or hexahedrons) or surfaces (triangles and quandrangles).
Diffstat (limited to 'science/medit/Makefile')
-rw-r--r--science/medit/Makefile93
1 files changed, 93 insertions, 0 deletions
diff --git a/science/medit/Makefile b/science/medit/Makefile
new file mode 100644
index 000000000000..131e2bc3c0bb
--- /dev/null
+++ b/science/medit/Makefile
@@ -0,0 +1,93 @@
+# New ports collection makefile for: Medit
+# Date created: Sep 24, 2006
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+
+PORTNAME= medit
+PORTVERSION= 2006.09.24
+CATEGORIES= science graphics
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.ann.jussieu.fr/~frey/logiciels/:author
+MASTER_SITE_SUBDIR= thierry
+EXTRACT_SUFX= .tgz
+DISTFILES= # See hereunder
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Interactive meshes visualization
+
+.if defined(MAINTAINER_MODE)
+DISTFILES+= ${PORTNAME}.${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-missing.${PORTVERSION}${EXTRACT_SUFX}
+MD5_FILE= ${MASTERDIR}/distinfo.src
+
+USE_GMAKE= yes
+MAKEFILE= makefile
+ALL_TARGET= ${OPSYS}
+MAKE_ENV= WRKSRC="${WRKSRC}" ARCHI=${OPSYS} ARCH=${ARCH} OSREL=${OSREL}
+
+PLIST_FILES= # nada
+MISSING_FILES= eigenv.c libmesh3.c libmesh3.h
+
+.else
+# We are not allowed to distribute the sources.
+DISTFILES+= ${PORTNAME}-${ARCH}-${DISTVER}-${PORTVERSION}${EXTRACT_SUFX}
+NO_BUILD= yes
+PATCHDIR= # No patches
+ONLY_FOR_ARCHS= i386 # Ask the maintainer to add one
+
+PLIST_FILES= bin/${PORTNAME}
+
+. if !defined(NOPORTDOCS)
+DISTFILES+= meshes.tar.gz:author
+MESHES= DEFAULT.medit ozark.gis part.bb part.mesh thepart.mesh
+PLIST_FILES+= ${MESHES:S|^|%%EXAMPLESDIR%%/|}
+PLIST_DIRS= %%EXAMPLESDIR%%
+. endif
+.endif
+
+LIB_DEPENDS+= glut.4:${PORTSDIR}/graphics/libglut
+
+NO_WRKSUBDIR= yes
+USE_GL= yes
+
+.include <bsd.port.pre.mk>
+
+. if ${OSVERSION} < 601000
+DISTVER= 4.11
+. if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+. endif
+. else
+DISTVER= 6.1
+. endif
+
+.if defined(MAINTAINER_MODE)
+
+post-extract:
+. for mf in ${MISSING_FILES}
+. if !exists(${WRKSRC}/sources/${mf})
+ ${CP} ${WRKSRC}/${mf} ${WRKSRC}/sources
+. endif
+. endfor
+
+pre-build:
+ ${MKDIR} ${WRKSRC}/bin/${ARCH}/${OSREL}
+
+tarball:
+ cd ${WRKSRC} && \
+ ${TAR} cvfz ${_DISTDIR}${PORTNAME}-${ARCH}-${OSREL}-${PORTVERSION}${EXTRACT_SUFX}\
+ bin/${ARCH}/${OSREL}
+
+.else # !MAINTAINER_MODE
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${ARCH}/${DISTVER}/${PORTNAME} ${PREFIX}/bin
+. if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${MESHES:S|^|${WRKSRC}/INRIA.dir/|} ${EXAMPLESDIR}
+. endif
+
+.endif
+
+.include <bsd.port.post.mk>