aboutsummaryrefslogtreecommitdiffstats
path: root/science/meep
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-14 19:20:54 +0800
committermiwi <miwi@FreeBSD.org>2013-03-14 19:20:54 +0800
commit4eb1612eadc8e2a5fdb343edda1418aa56e0d9aa (patch)
treea9204b90cc101be547e527fde78de45217b69fc4 /science/meep
parentce6e9471b02499cdef50832e574c8f5c838a7c00 (diff)
downloadfreebsd-ports-gnome-4eb1612eadc8e2a5fdb343edda1418aa56e0d9aa.tar.gz
freebsd-ports-gnome-4eb1612eadc8e2a5fdb343edda1418aa56e0d9aa.tar.zst
freebsd-ports-gnome-4eb1612eadc8e2a5fdb343edda1418aa56e0d9aa.zip
- Convert to Optionsng
- While here trim header
Diffstat (limited to 'science/meep')
-rw-r--r--science/meep/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/science/meep/Makefile b/science/meep/Makefile
index b20ef25752c7..1c3d7ca9d3be 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: science/meep
-# Date created: 26 Dec 2009
-# Whom: Stas Timokhin <devel@stasyan.com>
-#
+# Created by: Stas Timokhin <devel@stasyan.com>
# $FreeBSD$
-#
PORTNAME= meep
PORTVERSION= 1.1.1
@@ -35,11 +31,13 @@ LD_LIBRARY_PATH= -L${LOCALBASE}/lib -L/usr/lib
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= LD_LIBRARY_PATH="${LD_LIBRARY_PATH}"
-OPTIONS= OPENMPI "Enable MPI support using openmpi" On
+OPTIONS_DEFINE= OPENMPI
+OPTIONS_DEFAULT= OPENMPI
+OPENMPI_DESC= MPI support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENMPI)
+.if ${PORT_OPTIONS:MOPENMPI}
BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpiCC:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+=--with-mpi
@@ -54,4 +52,4 @@ post-patch:
${REINPLACE_CMD} -e 's+\#\! /bin/sh+\#\! ${PREFIX}/bin/bash+' \
-e s+\$$\(SHELL\)+${PREFIX}/bin/bash+ ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>