aboutsummaryrefslogtreecommitdiffstats
path: root/science/mpb
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-07 09:12:25 +0800
committerpav <pav@FreeBSD.org>2003-12-07 09:12:25 +0800
commit22153277e4c08891ead20753c9cef33cc219a2ed (patch)
tree966e3500af5a96ce7a3ad995639bd0380ce84f5e /science/mpb
parent91ed46bda04e86656b7d17803c75c398da29a9a9 (diff)
downloadfreebsd-ports-gnome-22153277e4c08891ead20753c9cef33cc219a2ed.tar.gz
freebsd-ports-gnome-22153277e4c08891ead20753c9cef33cc219a2ed.tar.zst
freebsd-ports-gnome-22153277e4c08891ead20753c9cef33cc219a2ed.zip
- Make it do actually something useful.
Make science/mpb has been pretty much useless because it wasn't correctly linked with hdf5 as it appears in the Makefile. Now this is properly done by linking pthread lib too, which is required by hdf5. Also, correctly link with ATLAS version of LAPACK. PR: ports/58337 Submitted by: AMAKAWA Shuhei <sa264@cam.ac.uk>
Diffstat (limited to 'science/mpb')
-rw-r--r--science/mpb/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index 3356f21fd83c..007185cf5ffb 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mpb
PORTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://ab-initio.mit.edu/mpb/
@@ -16,17 +17,21 @@ COMMENT= MIT Photonic-Bands
BUILD_DEPENDS= ${LOCALBASE}/lib/libctl.a:${PORTSDIR}/science/libctl \
bash:${PORTSDIR}/shells/bash2
-LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas \
- lapack.3:${PORTSDIR}/math/lapack \
- atlas.1:${PORTSDIR}/math/atlas \
+LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas \
fftw.2:${PORTSDIR}/math/fftw \
hdf5.0:${PORTSDIR}/graphics/hdf5 \
guile.15:${PORTSDIR}/lang/guile
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --with-lapack=-lalapack
MAN1= mpb.1 mpb-data.1 mpb-split.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lhdf5 |-lhdf5 ${PTHREAD_LIBS} |g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>