aboutsummaryrefslogtreecommitdiffstats
path: root/science/oof
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-13 02:58:44 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-13 02:58:44 +0800
commit0be530d411342b0d953ec50c56d1fc82dac72f85 (patch)
tree48358da2c7ef868ffeb15516cc1347c60ae11180 /science/oof
parentea9c8d772f70a4c0a3e9b6b0f22224fd85bb6e33 (diff)
downloadfreebsd-ports-gnome-0be530d411342b0d953ec50c56d1fc82dac72f85.tar.gz
freebsd-ports-gnome-0be530d411342b0d953ec50c56d1fc82dac72f85.tar.zst
freebsd-ports-gnome-0be530d411342b0d953ec50c56d1fc82dac72f85.zip
Objecto Oriented Finite Element Analysis of Real Material Microstructures
__________________ OOF is designed to help materials scientists calculate macroscopic properties from images of real or simulated microstructures. It is composed of two cooperating parts: ppm2oof and oof. ppm2oof reads images in the ppm (Portable Pixel Map) format and assigns material properties to features in the image. oof conducts virtual experiments on the data structures created by ppm2oof to determine the macroscopic properties of the microstructure. Currently, the programs calculate stresses and strains, but someday we hope to include thermal, electric, and magnetic field calculations. Check the Homepage for online manuals and new versions WWW: http://www.ctcms.nist.gov/oof/ PR: ports/98601 Submitted by: Pedro F. Giffuni
Diffstat (limited to 'science/oof')
-rw-r--r--science/oof/Makefile57
-rw-r--r--science/oof/distinfo3
-rw-r--r--science/oof/pkg-descr16
3 files changed, 76 insertions, 0 deletions
diff --git a/science/oof/Makefile b/science/oof/Makefile
new file mode 100644
index 000000000000..a9fe99f9f7ef
--- /dev/null
+++ b/science/oof/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: oof
+# Date created: 19 June 2006
+# Whom: Pedro F. Giffuni
+#
+# $FreeBSD$
+#
+
+PORTNAME= oof
+PORTVERSION= 1.037
+CATEGORIES= science
+MASTER_SITES= http://www.ctcms.nist.gov/~langer/OOFdownload/SRC/
+DISTNAME= ${PORTNAME}-dist${PORTVERSION}
+
+MAINTAINER= giffunip@asme.org
+COMMENT= Finite Element Analysis of Real Material Microstructures
+
+LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
+.ifdef WITH_ATLAS
+LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+.else
+LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+.endif
+
+.ifdef WITH_ATLAS
+BLAS_LIBS= -lf77blas -latlas
+.else
+BLAS_LIBS?= -lblas
+.endif
+
+CXXFLAGS+= -DDONT_HAVE_STRSTREAM_H -DNEED_FDSTREAM
+.ifdef WITH_THERMAL
+CXXFLAGS+= -DTHERMAL
+.endif
+CXXFLAGS+= -Wno-deprecated
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cxxflags='${CXXFLAGS}' \
+ --with-libdirs=-L${LOCALBASE}/lib \
+ --with-blas="-L${LOCALBASE}/lib ${BLAS_LIBS} -lg2c"
+USE_GCC= 3.2+
+
+ALL_TARGET= all
+PLIST_FILES= bin/oof bin/ppm2oof
+
+.ifndef WITH_THERMAL
+ALL_TARGET+= oof2abaqus
+PLIST_FILES+= bin/oof2abaqus
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/XOOF/oof ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/XPPM2OOF/ppm2oof ${PREFIX}/bin
+.ifndef WITH_THERMAL
+ @${INSTALL_PROGRAM} ${WRKSRC}/OOF2ABAQUS/oof2abaqus ${PREFIX}/bin
+.endif
+
+.include <bsd.port.mk>
diff --git a/science/oof/distinfo b/science/oof/distinfo
new file mode 100644
index 000000000000..884cec2d2df5
--- /dev/null
+++ b/science/oof/distinfo
@@ -0,0 +1,3 @@
+MD5 (oof-dist1.037.tar.gz) = 530012a1de4fc7a5a2df9a583fc942c6
+SHA256 (oof-dist1.037.tar.gz) = 1155c5cc340c744ac6bd99fcbe666fd77f715ff73a8c2f1a86afe5966e40a71b
+SIZE (oof-dist1.037.tar.gz) = 879554
diff --git a/science/oof/pkg-descr b/science/oof/pkg-descr
new file mode 100644
index 000000000000..7222b8a905ed
--- /dev/null
+++ b/science/oof/pkg-descr
@@ -0,0 +1,16 @@
+Objecto Oriented Finite Element Analysis of Real Material Microstructures
+__________________
+
+OOF is designed to help materials scientists calculate macroscopic
+properties from images of real or simulated microstructures. It is
+composed of two cooperating parts: ppm2oof and oof. ppm2oof reads images
+in the ppm (Portable Pixel Map) format and assigns material properties to
+features in the image. oof conducts virtual experiments on the data
+structures created by ppm2oof to determine the macroscopic properties of
+the microstructure. Currently, the programs calculate stresses and
+strains, but someday we hope to include thermal, electric, and magnetic
+field calculations.
+
+Check the Homepage for online manuals and new versions
+
+WWW: http://www.ctcms.nist.gov/oof/