aboutsummaryrefslogtreecommitdiffstats
path: root/science/paje
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-06 17:41:02 +0800
committermarino <marino@FreeBSD.org>2014-07-06 17:41:02 +0800
commit45292c1a2509fd6f19557740f03c1bdccaa36ce0 (patch)
tree3047d5b91da0cff9bdc867a241787ca3f0c9a062 /science/paje
parent4f4f2bf018bb900b51de1d9b7f0cafbb7c6f09f7 (diff)
downloadfreebsd-ports-gnome-45292c1a2509fd6f19557740f03c1bdccaa36ce0.tar.gz
freebsd-ports-gnome-45292c1a2509fd6f19557740f03c1bdccaa36ce0.tar.zst
freebsd-ports-gnome-45292c1a2509fd6f19557740f03c1bdccaa36ce0.zip
science/paje: Stage, bring in DragonFly support from dports
Diffstat (limited to 'science/paje')
-rw-r--r--science/paje/Makefile1
-rw-r--r--science/paje/files/patch-DrawView+Drawing.m8
-rw-r--r--science/paje/files/patch-DrawView+Finding.m4
3 files changed, 6 insertions, 7 deletions
diff --git a/science/paje/Makefile b/science/paje/Makefile
index 23a72aa13a0c..8cf17b766413 100644
--- a/science/paje/Makefile
+++ b/science/paje/Makefile
@@ -22,7 +22,6 @@ USE_GNUSTEP_INSTALL= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_LOCAL_ROOT}
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DOMAIN|#GNUSTEP_INSTALLATION_DOMAIN|' \
${WRKSRC}/GNUmakefile
diff --git a/science/paje/files/patch-DrawView+Drawing.m b/science/paje/files/patch-DrawView+Drawing.m
index f04b961e6cef..5fd8e53a52f0 100644
--- a/science/paje/files/patch-DrawView+Drawing.m
+++ b/science/paje/files/patch-DrawView+Drawing.m
@@ -1,14 +1,14 @@
--- SpaceTimeViewer/DrawView+Drawing.m.orig Mon Jan 9 02:13:30 2006
-+++ SpaceTimeViewer/DrawView+Drawing.m Thu Sep 28 20:56:39 2006
++++ SpaceTimeViewer/DrawView+Drawing.m
@@ -23,7 +23,11 @@
#include "DrawView.h"
#ifdef GNUSTEP
-+#ifndef __FreeBSD__
++# if !defined(__FreeBSD__) && !defined(__DragonFly__)
#include <values.h>
-+#else
++# else
+#include <math.h>
-+#endif
++# endif
#endif
@implementation DrawView (Drawing)
diff --git a/science/paje/files/patch-DrawView+Finding.m b/science/paje/files/patch-DrawView+Finding.m
index 3366f696805e..b16f75770b82 100644
--- a/science/paje/files/patch-DrawView+Finding.m
+++ b/science/paje/files/patch-DrawView+Finding.m
@@ -1,10 +1,10 @@
--- SpaceTimeViewer/DrawView+Finding.m.orig 2006-10-29 20:52:48.000000000 +0100
-+++ SpaceTimeViewer/DrawView+Finding.m 2012-01-14 08:09:36.000000000 +0100
++++ SpaceTimeViewer/DrawView+Finding.m
@@ -24,7 +24,9 @@
#include "DrawView.h"
#include <math.h>
-+#if !defined(__FreeBSD__)
++#if !defined(__FreeBSD__) && !defined(__DragonFly__)
#include <values.h>
+#endif