aboutsummaryrefslogtreecommitdiffstats
path: root/science/paraview
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-01-30 05:52:22 +0800
committerthierry <thierry@FreeBSD.org>2015-01-30 05:52:22 +0800
commit645e49f330aa242757192938e27f50a4e0c54a14 (patch)
tree973033be7c1ec412450fc39ffe7dad2437e7d9ad /science/paraview
parentab25c7cfbc9c670c3a7de2566e8eeeda2baf935c (diff)
downloadfreebsd-ports-gnome-645e49f330aa242757192938e27f50a4e0c54a14.tar.gz
freebsd-ports-gnome-645e49f330aa242757192938e27f50a4e0c54a14.tar.zst
freebsd-ports-gnome-645e49f330aa242757192938e27f50a4e0c54a14.zip
Unbreak.
Submitted by: Stas Timokhin (maintainer)
Diffstat (limited to 'science/paraview')
-rw-r--r--science/paraview/Makefile4
-rw-r--r--science/paraview/files/patch-VTK_Rendering_FreeType_vtkFreeTypeTools.cxx26
2 files changed, 28 insertions, 2 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index a2f405a377b7..1b8c21fbbc8b 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -16,8 +16,6 @@ LICENSE_NAME= ParaView_License
LICENSE_FILE= ${PATCH_WRKSRC}/License_v1.2.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN= Fails to build
-
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:${PORTSDIR}/math/py-matplotlib
LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5 \
libpng.so:${PORTSDIR}/graphics/png \
@@ -34,6 +32,8 @@ LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5 \
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:${PORTSDIR}/math/py-matplotlib
+CONFLICTS_BUILD= protobuf*
+
USE_QT4= qmake_build moc_build rcc_build uic_build \
linguist_build assistant_run qt3support \
dbus designer gui help-tools network script \
diff --git a/science/paraview/files/patch-VTK_Rendering_FreeType_vtkFreeTypeTools.cxx b/science/paraview/files/patch-VTK_Rendering_FreeType_vtkFreeTypeTools.cxx
new file mode 100644
index 000000000000..9b2723bff34e
--- /dev/null
+++ b/science/paraview/files/patch-VTK_Rendering_FreeType_vtkFreeTypeTools.cxx
@@ -0,0 +1,26 @@
+--- VTK/Rendering/FreeType/vtkFreeTypeTools.cxx.orig 2014-01-11 15:02:09.000000000 +0100
++++ VTK/Rendering/FreeType/vtkFreeTypeTools.cxx 2015-01-29 21:09:32.000000000 +0100
+@@ -1186,8 +1186,10 @@
+ if (bitmap)
+ {
+ metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
+- metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
+- metaData.descent);
++// metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
++// metaData.descent);
++ metaData.descent = std::min(-(static_cast<int>(bitmap->rows) - (bitmapGlyph->top - 1)),
++ metaData.descent);
+ }
+ ++heightString;
+ }
+@@ -1951,8 +1953,8 @@
+ if (bitmap)
+ {
+ bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
+- bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
+- bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
++ bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + static_cast<int>(bitmap->width));
++ bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - static_cast<int>(bitmap->rows));
+ bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
+ }
+ else