aboutsummaryrefslogtreecommitdiffstats
path: root/science/paraview
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /science/paraview
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'science/paraview')
-rw-r--r--science/paraview/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 8926a7ac5943..e91faf12a1e9 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -40,7 +40,7 @@ pre-patch:
${WRKDIR}/paraview-${PORTVERSION}/GUI/Widgets/CMakeLists.txt
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
${WRKDIR}/paraview-${PORTVERSION}/Utilities/TclTk/tk*/unix/configure
do-configure:
@@ -48,8 +48,8 @@ do-configure:
cd ${WRKSRC} && \
${LOCALBASE}/bin/cmake ../${DISTNAME} \
-DCMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
- -DCMAKE_C_FLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
+ -DCMAKE_C_FLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
-DPARAVIEW_USE_SYSTEM_HDF5=1 \
-DBUILD_SHARED_LIBS="ON" \
-DVTK_USE_SYSTEM_PNG="ON" \