aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-h5py
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-06-07 04:40:26 +0800
committerantoine <antoine@FreeBSD.org>2014-06-07 04:40:26 +0800
commitdcdb6dfb445175e64f28e873bd0c4840f1ec85b0 (patch)
tree0400cbcd03f8c1ea3c38821acfd9afdc13c99777 /science/py-h5py
parent19f674f1fde1550fc0209510118b88d82a0a0965 (diff)
downloadfreebsd-ports-gnome-dcdb6dfb445175e64f28e873bd0c4840f1ec85b0.tar.gz
freebsd-ports-gnome-dcdb6dfb445175e64f28e873bd0c4840f1ec85b0.tar.zst
freebsd-ports-gnome-dcdb6dfb445175e64f28e873bd0c4840f1ec85b0.zip
Mark BROKEN: Does not build
cc -DNDEBUG -O2 -pipe -fno-strict-aliasing -fPIC -DH5_USE_16_API -I/usr/local/lib/python2.7/site-packages/numpy/core/include -I/wrkdirs/usr/ports/science/py-h5py/work/h5py-2.2.1/lzf -I/usr/local/include -I/usr/local/include/python2.7 -c h5py/h5fd.c -o build/temp.freebsd-10.0-RELEASE-p3-amd64-2.7/h5py/h5fd.o In file included from h5py/h5fd.c:259: In file included from h5py/api_compat.h:21: In file included from /usr/local/lib/python2.7/site-packages/numpy/core/include/numpy/arrayobject.h:4: In file included from /usr/local/lib/python2.7/site-packages/numpy/core/include/numpy/ndarrayobject.h:17: In file included from /usr/local/lib/python2.7/site-packages/numpy/core/include/numpy/ndarraytypes.h:1761: /usr/local/lib/python2.7/site-packages/numpy/core/include/numpy/npy_1_7_deprecated_api.h:15:2: warning: "Using deprecated NumPy API, disable it by " "#defining NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION" [-W#warnings] #warning "Using deprecated NumPy API, disable it by " \ ^ h5py/h5fd.c:857:39: error: use of undeclared identifier 'H5FD_MPIPOSIX' __pyx_t_1 = __Pyx_PyInt_to_py_hid_t(H5FD_MPIPOSIX); if (unlikely(!__pyx_t_1)) {__pyx_filename = __pyx_f[0]; __pyx_lineno = 34; __pyx_clineno = __LINE__; goto __pyx_L1_error;} ^ 1 warning and 1 error generated. error: command 'cc' failed with exit status 1 *** Error code 1 Reported by: pkg-fallout
Diffstat (limited to 'science/py-h5py')
-rw-r--r--science/py-h5py/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index 1efd80f4e308..2dbe5255d484 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -13,6 +13,8 @@ COMMENT= General-purpose Python interface to the HDF5 library
LICENSE= BSD
+BROKEN= Does not build
+
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5