aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-mlpy/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2014-05-31 21:56:17 +0800
committerwen <wen@FreeBSD.org>2014-05-31 21:56:17 +0800
commit2e1ccfe643c335e40041dec939af05b97f9d5d6d (patch)
tree4b450ffcda86bcd0ac3f184bbbfc85e0e7b37f8e /science/py-mlpy/Makefile
parent4616ee9b8a7cbf2100e702214333fea120aba3b4 (diff)
downloadfreebsd-ports-gnome-2e1ccfe643c335e40041dec939af05b97f9d5d6d.tar.gz
freebsd-ports-gnome-2e1ccfe643c335e40041dec939af05b97f9d5d6d.tar.zst
freebsd-ports-gnome-2e1ccfe643c335e40041dec939af05b97f9d5d6d.zip
- Added STAGE support
- Update to 3.5.0 PR: 190314 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'science/py-mlpy/Makefile')
-rw-r--r--science/py-mlpy/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
index 95cbce39caa7..60bf37b8b4a2 100644
--- a/science/py-mlpy/Makefile
+++ b/science/py-mlpy/Makefile
@@ -2,26 +2,26 @@
# $FreeBSD$
PORTNAME= mlpy
-PORTVERSION= 2.2.2
-PORTREVISION= 4
+PORTVERSION= 3.5.0
CATEGORIES= science python
-MASTER_SITES= https://mlpy.fbk.eu/download/src/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= MLPY-${PORTVERSION}
MAINTAINER= wen@FreeBSD.org
COMMENT= High performance Python package for predictive modeling
+LICENSE= GPLv3
+
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
cython>0:${PORTSDIR}/lang/cython
RUN_DEPENDS:= ${BUILD_DEPENDS}
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
+USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -I${PYTHON_SITELIBDIR}/numpy/core
LDFLAGS+= -L${LOCALBASE}/lib
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= MLPY
+PYDISTUTILS_AUTOPLIST= yes
-NO_STAGE= yes
.include <bsd.port.mk>