aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-pyteomics
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2015-11-02 17:24:50 +0800
committermakc <makc@FreeBSD.org>2015-11-02 17:24:50 +0800
commit2c930491150a29175bd266ba5051e3e0f24fd1df (patch)
tree7ff807b6a90a93629ec1fb910c20f529f66ae38a /science/py-pyteomics
parentf5352d12c71ab77488846f05ea40b7a1301275b4 (diff)
downloadfreebsd-ports-gnome-2c930491150a29175bd266ba5051e3e0f24fd1df.tar.gz
freebsd-ports-gnome-2c930491150a29175bd266ba5051e3e0f24fd1df.tar.zst
freebsd-ports-gnome-2c930491150a29175bd266ba5051e3e0f24fd1df.zip
Rename my ports to comply with Python ports policy
Requested by: koobs
Diffstat (limited to 'science/py-pyteomics')
-rw-r--r--science/py-pyteomics/Makefile20
-rw-r--r--science/py-pyteomics/distinfo2
-rw-r--r--science/py-pyteomics/pkg-descr16
3 files changed, 38 insertions, 0 deletions
diff --git a/science/py-pyteomics/Makefile b/science/py-pyteomics/Makefile
new file mode 100644
index 000000000000..f48b9b45ce08
--- /dev/null
+++ b/science/py-pyteomics/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= pyteomics
+PORTVERSION= 2.4.0
+PORTREVISION= 1
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Python modules for proteomics data analysis
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:${PORTSDIR}/math/py-matplotlib \
+ ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/science/py-pyteomics/distinfo b/science/py-pyteomics/distinfo
new file mode 100644
index 000000000000..f32435ebbc0b
--- /dev/null
+++ b/science/py-pyteomics/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyteomics-2.4.0.tar.gz) = 81ae2378dc306efc89d2cf70edd3582b858b26dd6ade42903969f85e0b33ceec
+SIZE (pyteomics-2.4.0.tar.gz) = 103539
diff --git a/science/py-pyteomics/pkg-descr b/science/py-pyteomics/pkg-descr
new file mode 100644
index 000000000000..f30cbd1b1687
--- /dev/null
+++ b/science/py-pyteomics/pkg-descr
@@ -0,0 +1,16 @@
+Pyteomics is a collection of lightweight and handy tools for Python
+that help to handle various sorts of proteomics data. Pyteomics
+provides a growing set of modules to facilitate the most common
+tasks in proteomics data analysis, such as:
+
+ * calculation of basic physico-chemical properties of polypeptides:
+ . mass and isotopic distribution
+ . charge and pI
+ . chromatographic retention time
+ * access to common proteomics data:
+ . MS or LC-MS data
+ . FASTA databases
+ . search engines output
+ * easy manipulation of sequences of modified peptides and proteins
+
+WWW: https://pypi.python.org/pypi/pyteomics