aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-scipy/Makefile
diff options
context:
space:
mode:
authorxride <xride@FreeBSD.org>2006-10-08 01:16:43 +0800
committerxride <xride@FreeBSD.org>2006-10-08 01:16:43 +0800
commitfe5ba0412aa06d9fa74a8cab04509741ccf9bc47 (patch)
treec2f3ce01116203b504308c010b41d4ab5b8a254b /science/py-scipy/Makefile
parente826519c5038efc86bc6553404a59ccbcb3446a6 (diff)
downloadfreebsd-ports-gnome-fe5ba0412aa06d9fa74a8cab04509741ccf9bc47.tar.gz
freebsd-ports-gnome-fe5ba0412aa06d9fa74a8cab04509741ccf9bc47.tar.zst
freebsd-ports-gnome-fe5ba0412aa06d9fa74a8cab04509741ccf9bc47.zip
depends on atlas when it could also be built with lapack/blas instead
this diff adds an OPTION knob to allow selection at compile time. PR: 104077 Submitted by: maintainer Approved by: tmclaugh (mentor)
Diffstat (limited to 'science/py-scipy/Makefile')
-rw-r--r--science/py-scipy/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 88fe0aca95df..bc3f7b732d57 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -8,7 +8,7 @@
PORTNAME= scipy
PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scipy
@@ -22,11 +22,11 @@ BUILD_DEPENDS= ${PYNUMERIC} \
${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft \
f2py:${PORTSDIR}/lang/f2py \
${PYTHON_SITELIBDIR}/wx/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython24
-LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
- atlas.1:${PORTSDIR}/math/atlas
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+OPTIONS= ATLAS "Use optimized blas library" OFF
post-patch:
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
@@ -34,9 +34,15 @@ post-patch:
.include <bsd.port.pre.mk>
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
.if !exists(${LOCALBASE}/lib/libalapack.a)
IGNORE= Atlas needs to be built with WITH_STATICLIB for scipy to function properly
.endif
+.else
+LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack \
+ blas.1:${PORTSDIR}/math/blas
+.endif
post-install:
@${RMDIR} ${PYTHON_SITELIBDIR}/weave/swig # empty