aboutsummaryrefslogtreecommitdiffstats
path: root/science/rubygem-ai4r/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-25 20:08:20 +0800
committermiwi <miwi@FreeBSD.org>2011-03-25 20:08:20 +0800
commit6412f757d24f6d321273d618fdc47c9b306a35ff (patch)
tree82d4b6ce34707d98e8d3df1e6a533d8741d5872b /science/rubygem-ai4r/Makefile
parentad5b6da00179031d119e978666df982abc90aa02 (diff)
downloadfreebsd-ports-gnome-6412f757d24f6d321273d618fdc47c9b306a35ff.tar.gz
freebsd-ports-gnome-6412f757d24f6d321273d618fdc47c9b306a35ff.tar.zst
freebsd-ports-gnome-6412f757d24f6d321273d618fdc47c9b306a35ff.zip
AI4R is a collection of ruby algorithms implementations,
covering several Artificial intelligence fields. It implements: * Genetic algorithms * Self-organized maps (SOM) * Neural Networks - Multilayer perceptron with Backpropagation learning - Hopfield net * Automatic classifiers (Machine Learning) - ID3 (Decision Trees) - PRISM (J. Cendrowska, 1987) - Multilayer Perceptron - OneR (AKA One Attribute Rule, 1R) - ZeroR - Hyperpipes - Naive Bayes - IB1 (D. Aha, D. Kibler - 1991) * Data clustering - K-means - Bisecting k-means - Single linkage - Complete linkage - Average linkage - Weighted Average linkage - Centroid linkage - Median linkage - Ward's method linkage - Diana (Divisive Analysis) WWW: http://ai4r.rubyforge.org/ PR: ports/155699 Submitted by: Eric Freeman <freebsdports at chillibear.com>
Diffstat (limited to 'science/rubygem-ai4r/Makefile')
-rw-r--r--science/rubygem-ai4r/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/science/rubygem-ai4r/Makefile b/science/rubygem-ai4r/Makefile
new file mode 100644
index 000000000000..ce0ef81d86fe
--- /dev/null
+++ b/science/rubygem-ai4r/Makefile
@@ -0,0 +1,20 @@
+# Ports collection makefile for: rubygem-ai4r
+# Date created: 19 Mar 2011
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ai4r
+PORTVERSION= 1.9
+CATEGORIES= science rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Ruby implementations of artificial intelligence algorithms
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>