aboutsummaryrefslogtreecommitdiffstats
path: root/science/simlib/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-28 05:38:03 +0800
committerpav <pav@FreeBSD.org>2004-11-28 05:38:03 +0800
commit0b74fdd5301b8a28a7d75c29f013485a8c989f88 (patch)
treee8597a2076aa0987c680b1fa0f2f88122a0a2a7b /science/simlib/Makefile
parent09df779aa00fdce7f3a3ec575011313819c5f37a (diff)
downloadfreebsd-ports-gnome-0b74fdd5301b8a28a7d75c29f013485a8c989f88.tar.gz
freebsd-ports-gnome-0b74fdd5301b8a28a7d75c29f013485a8c989f88.tar.zst
freebsd-ports-gnome-0b74fdd5301b8a28a7d75c29f013485a8c989f88.zip
SIMLIB/C++ is the SIMulation LIBrary for C++ programming language. You can
create models directly in C++ language with the use of predefined simulation tools from the library. SIMLIB allows object-oriented description of models based on simulation abstractions. Current version allows a description of continuous, discrete, combined, 2D/3D vector, and fuzzy models. Requested by: Roman Divacky
Diffstat (limited to 'science/simlib/Makefile')
-rw-r--r--science/simlib/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/science/simlib/Makefile b/science/simlib/Makefile
new file mode 100644
index 000000000000..01d0bae13e93
--- /dev/null
+++ b/science/simlib/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: simlib
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+# Date created: 26 Nov 2004
+#
+# $FreeBSD$
+#
+
+PORTNAME= simlib
+PORTVERSION= 2.18.20041107
+CATEGORIES= science
+MASTER_SITES= http://www.fit.vutbr.cz/~peringer/SIMLIB/source/
+DISTNAME= SIMLIB-${PORTVERSION:S/.200/-200/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= SIMulation LIBrary for C++ programming language
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}
+MAKEFILE= Makefile.FreeBSD
+INSTALL_TARGET= _install
+
+# not 64bit ready
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.mk>