aboutsummaryrefslogtreecommitdiffstats
path: root/science/tfel/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2017-05-05 04:30:48 +0800
committerthierry <thierry@FreeBSD.org>2017-05-05 04:30:48 +0800
commit95f48943e27398d4abcfe5808f0ef5e860385768 (patch)
treeeea02d936edc0a48078a3e7bc2e10999e91dc3a0 /science/tfel/Makefile
parent2eb578f10a8ab315f7ac3b2d57ddbd26550b9ac4 (diff)
downloadfreebsd-ports-gnome-95f48943e27398d4abcfe5808f0ef5e860385768.tar.gz
freebsd-ports-gnome-95f48943e27398d4abcfe5808f0ef5e860385768.tar.zst
freebsd-ports-gnome-95f48943e27398d4abcfe5808f0ef5e860385768.zip
Cleanup.
PR: 216315 Submitted by: pfg
Diffstat (limited to 'science/tfel/Makefile')
-rw-r--r--science/tfel/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/science/tfel/Makefile b/science/tfel/Makefile
index 5c2213c18f97..7b0d79a8ecac 100644
--- a/science/tfel/Makefile
+++ b/science/tfel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tfel
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/
PKGNAMESUFFIX= -mfront
@@ -14,18 +15,23 @@ LICENSE= GPLv3
OPTIONS_DEFINE= GNUPLOT PYTHON
OPTIONS_DEFAULT= GNUPLOT
+
GNUPLOT_BUILD_DEPENDS= gnuplot:math/gnuplot
GNUPLOT_RUN_DEPENDS= gnuplot:math/gnuplot
+PYTHON_CONFIGURE_ENABLE= python
+PYTHON_USES= python
+
ONLY_FOR_ARCHS= amd64 i386
USES= autoreconf libtool tar:bzip2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-aster
+CONFIGURE_ARGS+= --enable-aster
USE_LDCONFIG= yes
-PYTHON_CONFIGURE_ENABLE= python
-PYTHON_USES= python
+.ifdef PACKAGE_BUILDING
+CONFIGURE_ARGS+= --enable-portable-build
+.endif
INSTALL_TARGET= install-strip
TEST_TARGET= check