aboutsummaryrefslogtreecommitdiffstats
path: root/science/vis5d+
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /science/vis5d+
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'science/vis5d+')
-rw-r--r--science/vis5d+/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index c1ddc800d34a..25ce8373f168 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -35,13 +35,13 @@ USE_GNOME= gtk12
USE_ICONV= yes
GNU_CONFIGURE= yes
FFLAGS+= -fno-range-check
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" LIBS="-lgfx"
+CONFIGURE_ENV+= LIBS="-lgfx"
CONFIGURE_ARGS= --enable-gtk --enable-threads --with-netcdf \
--with-mixkit=${LOCALBASE}/lib/libmix.a --with-x
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= -DMIX_ANSI_IOSTREAMS -fPIC -fpermissive